hdu 3466 Proud Merchants

 

Problem Description

 

Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?


 


 

Input

 

There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.


 


 

Output

 

For each test case, output one integer, indicating maximum value iSea could get.

 


 

Sample Input

 

  
  
2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
 


 

Sample Output

 

  
  
5 11
 


 

题目大意给定n个物品和钱m,每个物品有价格p,限制钱数q,价值v,限制q的意思是你手头的前必须大等于q才能装买这个物品,问最后获得的最大价值。n<=500,m<=5000.

 

解题思路:

               在网上看了好多的讲解,至今也没弄明白为什么是按照q-p排序,但是这却是关键。

                这里提供一下其他人的讲解:http://blog.csdn.net/oceanlight/article/details/7866759   

代码:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <cstring>
using namespace std;

struct node
{
    int p,q,w;
} a[5100];

bool cmp(node a,node b)
{
    return a.p-a.q>b.p-b.q;
}
int main()
{
    int n,m,f[5100];
    while(scanf("%d%d",&n,&m)!=EOF)
    {

        int i;
        memset(f,0,sizeof(f));
        
        for(i=0; i<n; i++)
            scanf("%d%d%d",&a[i].p,&a[i].q,&a[i].w);
            
        sort(a,a+n,cmp);
        
        for(i=0; i<n; i++)
            for(int v=m; v>=a[i].p; v--)
                if(v>=a[i].q)
                    f[v]=max(f[v],f[v-a[i].p]+a[i].w);
        printf("%d\n",f[m]);
    }

    return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值