hdu 2795 Billboard(线段树)

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10890    Accepted Submission(s): 4827


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1
 


题解及代码:


#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <set>
#include <map>
#include <queue>
#include <string>
#define maxn 200010
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define ALL %I64d
using namespace std;
typedef long long  ll;


struct segment
{
    int l,r;
    int value;
} son[maxn<<2];

void PushUp(int rt)
{
    son[rt].value=max(son[rt<<1].value,son[rt<<1|1].value);
}

void Build(int value,int l,int r,int rt)
{
    son[rt].l=l;
    son[rt].r=r;
    son[rt].value=value;
    if(l==r)
    {
        return;
    }
    int m=(l+r)/2;
    Build(value,lson);
    Build(value,rson);
}


int Query(int w,int rt)
{
    if(son[rt].l==son[rt].r)
    {
        son[rt].value-=w;
        return son[rt].l;
    }

    int m=(son[rt].l+son[rt].r)/2;
    int ret=0;

    if(son[rt<<1].value>=w)
        ret=Query(w,rt<<1);
    else ret=Query(w,rt<<1|1);

    PushUp(rt);
    return ret;
}

int main()
{
    int n,w,t;
    while(scanf("%d%d%d",&n,&w,&t)!=EOF)
    {
        n=min(n,t);      //n的最大值超过我们容忍的范围,但是t却没超过
                         //所以我们取两者更小的那一个
        Build(w,1,n,1);

        for(int i=0; i<t; i++)
        {
            scanf("%d",&w);
            if(son[1].value>=w)
                printf("%d\n",Query(w,1));
            else printf("-1\n");
        }
    }
    return 0;
}
/*
我们使用线段树记录从l到第r行的长度的最大值,
当我们想要插入一个广告就代表我们从黑板的每行中找对应的满足情况的那一行,
那我们可以查看线段树左侧的最大值和右侧的最大值,
当左侧有满足情况的一行时,我们就想做寻找,当没有的时候,就去右侧寻找,
如果两侧都没有,那么我就该输出-1。

当我们找到满足的那一行的时候,我们把当前行的value减去广告的长度,
然后回溯维护整个线段树的最大值区间。
*/






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值