尺取法--poj3320

Language:
Jessica's Reading Problem
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6139 Accepted: 1856

Description

Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1

Sample Output

2

今天学习了一下《挑战程序设计竞赛》的尺取法,就是通过两个数组下标的交替移动直到得出答案。

下面是代码:
#include<iostream>
#include<map>
#include<set>
#include<cstdio>
using namespace std;
int a[1000010],P;
void solve()
{
    set<int> dian;
    for(int i=0;i<P;i++)
        dian.insert(a[i]);
    int n=dian.size();
    int s=0,t=0,num=0;
    map<int,int> count;
    int res=P;
    while(1)
    {
        while(t<P&&num<n)
        {
            if(count[a[t++]]++==0)//出现新的知识点
                num++;
        }
        if(num<n)
            break;
        res=min(res,t-s);
        if(--count[a[s++]]==0)//去掉s知识点
            num--;
    }
    printf("%d\n",res);
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(scanf("%d",&P)!=EOF)
    {
        for(int i=0;i<P;i++)
            scanf("%d",&a[i]);
        solve();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值