POJ_2891_Strange Way to Express Integers(非互质的中国剩余定理)

Strange Way to Express Integers
Time Limit: 1000MS Memory Limit: 131072K
Total Submissions: 8237 Accepted: 2466

Description

Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:

Choose k different positive integers a1a2…, ak. For some non-negative m, divide it by every ai (1 ≤ i ≤ k) to find the remainder ri. If a1a2, …, ak are properly chosen, m can be determined, then the pairs (airi) can be used to express m.

“It is easy to calculate the pairs from m, ” said Elina. “But how can I find m from the pairs?”

Since Elina is new to programming, this problem is too difficult for her. Can you help her?

Input

The input contains multiple test cases. Each test cases consists of some lines.

  • Line 1: Contains the integer k.
  • Lines 2 ~ k + 1: Each contains a pair of integers airi (1 ≤ i ≤ k).

Output

Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output -1.

Sample Input

2
8 7
11 9

Sample Output

31

Hint

All integers in the input and the output are non-negative and can be represented by 64-bit integral types.

Source


题型:数论(非互质的中国剩余定理)


题意:求同余方程组的解


分析:

一眼就看出跟中国剩余定理有关,但是不能用,因为{ a1,a2,……an }不一定是互质的,那肿麽办咧?

采用两两合并的思想:
                                                X ≡ r1 ( mod a1 )
                                                X ≡ r2 ( mod a2 )
推得:
                                                X = k1 * a1 + r1
                                                X = k2 * a2 + r2
所以:                             k1 * a1 + r1 = k2 * a2 + r2
推得:                             k1 * a1 ≡ ( r2 - r1 ) ( mod a2 )
解模线性方程求得最小的 k1
然后得到:                              X = k1 * a1 + r1
令:                                 r = x 、a = lcm ( a1 , a2 )
然后就可以组成另一个式子:
                                                X ≡ r ( mod a )
将这个式子与下一个式子继续像上述一样合并,一直到最后一个并完,r 就是答案。


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define LL long long
using namespace std;

LL gcd(LL a,LL b){
    return b ? gcd(b,a%b) : a;
}
LL lcm(LL a,LL b){
    return a/gcd(a,b)*b;
}

LL extgcd(LL a,LL b,LL & x,LL & y){
    if(b==0){
        x=1;
        y=0;
        return a;
    }
    LL d=extgcd(b,a%b,x,y);
    LL t=x;
    x=y;
    y=t-a/b*y;
    return d;
}
/*
LL modeq(LL a,LL b,LL n){
    LL e,i,d,x,y;
    d=extgcd(a,n,x,y);
    e=(x*(b/d))%n;
    return ((e%n+n)%n);
}
*/

long long modeq(long long a,long long b,long long n){
	long long x,y,d,b1;
	d=extgcd(a,n,x,y);
	b1=(n/d)<0 ? -n/d : n/d;
	x*=b/d;
	return (x%b1+b1)%b1;
}

int main(){
    LL t,a,r,a1,r1,a2,r2,k1,d;
    while(~scanf("%I64d",&t)){
        bool flag=1;
        scanf("%I64d%I64d",&a1,&r1);
        for(int i=1;i<t;i++){
            scanf("%I64d%I64d",&a2,&r2);
            d=gcd(a1,a2);
            if((r2-r1)%d!=0){
                flag=0;
            }
            else{
                k1=modeq(a1,(r2-r1),a2);
                r1=k1*a1+r1;
                a1*=(a2/d);
                //a1=lcm(a1,a2);
            }
        }
        if(!flag){
            printf("-1\n");
        }
        else{
            printf("%I64d\n",r1);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值