poj_2409_Let it Bead(polya计数)

Let it Bead
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3967 Accepted: 2593

Description

"Let it Bead" company is located upstairs at 700 Cannery Row in Monterey, CA. As you can deduce from the company name, their business is beads. Their PR department found out that customers are interested in buying colored bracelets. However, over 90 percent of the target audience insists that the bracelets be unique. (Just imagine what happened if two women showed up at the same party wearing identical bracelets!) It's a good thing that bracelets can have different lengths and need not be made of beads of one color. Help the boss estimating maximum profit by calculating how many different bracelets can be produced. 

A bracelet is a ring-like sequence of s beads each of which can have one of c distinct colors. The ring is closed, i.e. has no beginning or end, and has no direction. Assume an unlimited supply of beads of each color. For different values of s and c, calculate the number of different bracelets that can be made.

Input

Every line of the input file defines a test case and contains two integers: the number of available colors c followed by the length of the bracelets s. Input is terminated by c=s=0. Otherwise, both are positive, and, due to technical difficulties in the bracelet-fabrication-machine, cs<=32, i.e. their product does not exceed 32.

Output

For each test case output on a single line the number of unique bracelets. The figure below shows the 8 different bracelets that can be made with 2 colors and 5 beads.

Sample Input

1 1
2 1
2 2
5 1
2 5
2 6
6 2
0 0

Sample Output

1
2
3
5
8
13
21

Source


题型:组合数学


题意:串手链,有c种颜色的珍珠串成s长的手链,求可以串出多少种不一样的手链。


分析:polya计数法。


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define LL long long
using namespace std;
int c,s;
int gcd(int a,int b){
    if(b==0) return a;
    return gcd(b,a%b);
}
LL polya(){
    int i,j;
    LL ans=0;
    for(i=0;i<s;i++)
        ans+=(LL)pow(1.0*c,gcd(s,i));
    if(s%2)
        ans+=s*(LL)pow(1.0*c,s/2+1);
    else{
        ans+=s/2*(LL)pow(1.0*c,s/2);
        ans+=s/2*(LL)pow(1.0*c,s/2+1);
    }
    return ans/2/s;
}


int main(){
    while(scanf("%d%d",&c,&s)){
        if(c==0&&s==0) break;
        LL ans=polya();
        printf("%I64d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值