POJ2965 The Pilots Brothers' refrigerator 「BFS+状态压缩」

题目链接:http://poj.org/problem?id=2965

The Pilots Brothers' refrigerator
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 18590   Accepted: 7116   Special Judge

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4

Source

Northeastern Europe 2004, Western Subregion

#include <iostream>
#include <queue>
#include <string.h>
#include <cstdio>
using namespace std;

const int maxn = 1 << 16;
int s[4][4];
char s1[4][4];
bool vis[maxn];
int pre[maxn];
int prex[maxn];
int prey[maxn];
int rex[maxn];
int rey[maxn];
int q[maxn];
int bits[16] = {1, 2, 4, 8, 16, 32, 64, 128, 256, 512, 1024, 2048, 4096, 8192, 16384, 32768};
int flip[4][4] = {4383, 8751, 17487, 34959, 4593, 8946, 17652, 35064, 7953, 12066, 20292, 36744, 61713, 61986, 62532, 63624};

int zip(int s[4][4])
{
        int sum = 0;
        for (int i = 0; i < 4; ++i)
                for (int j = 0; j < 4; ++j)
                        if (s[i][j])
                                sum += bits[i * 4 + j];
        return sum;
}

void unzip(int num)
{
        memset(s, 0, sizeof(s));
        for (int i = 0; i < 16; ++i)
                if (num & bits[i])
                        s[i / 4][i % 4] = 1;
}

int main()
{
        for (int i = 0; i < 4; ++i)
                scanf("%s", s1[i]);
        memset(s, 0, sizeof(s));
        memset(vis, false, sizeof(vis));
        for (int i = 0; i < 4; ++i)
                for (int j = 0; j < 4; ++j)
                        if (s1[i][j] == '+')
                                s[i][j] = 1;
        int num = zip(s);
        int t;
        int head = 0, tail = 0;
        q[head] = num;
        tail++;
        vis[num] = true;
        while (true) {
                t = q[head++];
                if (t == 0)
                        break;
                unzip(t);
                for (int i = 0; i < 4; ++i)
                        for (int j = 0; j < 4; ++j) {
                                int x = t ^ flip[i][j];
                                if (!vis[x]) {
                                        q[tail++] = x;
                                        vis[x] = true;
                                        pre[x] = t;
                                        prex[x] = i;
                                        prey[x] = j;
                                }
                        }
        }

        int k = 0;
        while (t != num) {
                rex[k] = prex[t];
                rey[k++] = prey[t];
                t = pre[t];
        }
        printf("%d\n", k);
        for (int i = k - 1; i >= 0; --i)
                printf("%d %d\n", rex[i] + 1, rey[i] + 1);

}


G++ 594ms


比较暴力一点,网上有高效的方法。

这里主要是用数组记录了位移运算的值,避免重复进行位移运算;

另外,反转是可以用异或实现的,进行异或的值也用一个数组存起来。


异或数组生成代码:

#include <iostream>
#include <string.h>
using namespace std;

int main()
{
        int s[4][4];
        for (int i = 0; i < 4; ++i)
                for (int j = 0; j < 4; ++j) {
                        memset(s, 0, sizeof(s));
                        for (int x = 0; x < 4; ++x) {
                                s[x][j] = 1;
                                s[i][x] = 1;
                        }
                        int sum = 0;
                        for (int i = 0; i < 4; ++i)
                                for (int j = 0; j < 4; ++j)
                                        if (s[i][j])
                                                sum += (1 << (i * 4 + j));
                        cout << sum << ", ";
                }

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值