POJ 2229:Sumsets

Sumsets
Time Limit: 2000MS Memory Limit: 200000K
Total Submissions: 14930 Accepted: 5965

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7: 

1) 1+1+1+1+1+1+1 
2) 1+1+1+1+1+2 
3) 1+1+1+2+2 
4) 1+1+1+4 
5) 1+2+2+2 
6) 1+2+4 

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000). 

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

题意是给出一个数,给出这个数能够被2的指数相加的方式数量。

x是奇数的话,发现dp[x]=dp[x-1]

x是偶数的话,dp[x]=dp[x-1]+dp[x/2] dp[x-1]可以看作是有1的那部分,没有1的那部分最小的就是2,将每个数除以2之后发现就是x/2的方式数。

代码:

#pragma warning(disable:4996)  
#include <iostream>  
#include <algorithm>  
#include <cmath>  
#include <vector>  
#include <string>  
#include <cstring>
#include <queue>
#include <map>
#include <cstdio>
#include <stdio.h>
using namespace std;
typedef long long ll;

const int mod = 1e9;

int n;
int dp[1000001];

int main()
{
	//freopen("i.txt", "r", stdin);
	//freopen("o.txt", "w", stdout);
	
	int i;
	cin >> n;
	
	dp[0] = 0;
	dp[1] = 1;
	for (i = 2; i <= n; i++)
	{
		if (i & 1)
			dp[i] = dp[i - 1];
		else
			dp[i] = (dp[i - 1] + dp[i >> 1]) % mod;
	}
	cout << dp[n] << endl;
	//system("pause");
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值