关闭

Eclipse中编译和运行时使用的JDK和JRE级别问题(关于"Bad version number in .class file"的异常解决)

标签: Bad version number iJava基础加强异常错误的版本号Eclipse
255人阅读 评论(0) 收藏 举报
分类:

"Bad version number in .class file"异常,意思是“错误的版本号”。

这是由于在Eclipse中编译Java程序时所用的JDK版本高于运行时所用的JRE版本所致。如编译用JDK1.6,而运行时的JRE为1.5版本。在1.5的运行时环境版本上运行1.6的程序,当然不行。而反过来却可以,因为软件通常都有所谓的“向后兼容性”。

具体解决办法:在Eclipse中设置JDK的编译级别:Window-->Preference-->Java-->Compiler中,设置compiler compliance level(这里的5.0对应JDK1.5,6.0对应JDK1.6); 设置JRE版本:Window-->Preference-->Java

-- >Installed JREs,选择一个JRE就行了。只要保证前者(JDK)的版本号小于或等于后者(JRE)的版本号就可以了

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:23699次
    • 积分:602
    • 等级:
    • 排名:千里之外
    • 原创:37篇
    • 转载:6篇
    • 译文:0篇
    • 评论:0条
    文章存档