Tree UVA548



  Tree 

You are to determine the value of the leaf node in a given binary tree that is the terminal node of a path of least value from the root of the binary tree to any leaf. The value of a path is the sum of values of nodes along that path.

Input 

The input file will contain a description of the binary tree given as the inorder and postorder traversal sequences of that tree. Your program will read two line (until end of file) from the input file. The first line will contain the sequence of values associated with an inorder traversal of the tree and the second line will contain the sequence of values associated with a postorder traversal of the tree. All values will be different, greater than zero and less than 10000. You may assume that no binary tree will have more than 10000 nodes or less than 1 node.

Output 

For each tree description you should output the value of the leaf node of a path of least value. In the case of multiple paths of least value you should pick the one with the least value on the terminal node.

Sample Input 

3 2 1 4 5 7 6
3 1 2 5 6 7 4
7 8 11 3 5 16 12 18
8 3 11 7 16 18 12 5
255
255

Sample Output 

1
3
255



Miguel A. Revilla 
1999-01-11

这道题的做法很简单,就是根据二叉树的中序和后序序列建树,然后遍历这棵树。

但是我经过无数次的wa,rte之后才AC的。首先建树就出现问题,之后遍历时用DFS方法也不正确。DFS还是不怎么会用。

#include<iostream>
#include<string>
#include<cstring>
#include<algorithm>
#include<vector>
#define maxn 10005

using namespace std;

class Node
{
public:
    int data;
    Node *ld,*rd;
};

int arry1[maxn],arry2[maxn];
int ans,pos;

Node* CreateTree(int n,int *arry1,int *arry2)
{
    if(n<=0) return NULL;
    int k=0;
    while(arry1[k]!=arry2[n-1])
        k++;
    Node *root=new Node;
    root->data=arry2[n-1];
    root->ld=CreateTree(k,arry1,arry2);
    root->rd=CreateTree(n-k-1,arry1+1+k,arry2+k);
    return root;
}

void FreeTree(Node *u)
{
    if(u==NULL) return;
    FreeTree(u->ld);
    FreeTree(u->rd);
    delete u;
}

void dfs(Node *u,int m)
{
    if(u==NULL) return;
    m=m+u->data;
    if(u->ld==NULL&&u->rd==NULL)
    {
        if(m<ans)
        {
            ans=m;
            pos=u->data;
        }
        return;
    }
    dfs(u->ld,m);
    dfs(u->rd,m);
}

int main()
{
    int n;
    char ch;
    while(cin>>n)
    {
        memset(arry1,0,sizeof(arry1));
        memset(arry2,0,sizeof(arry2));
        int i=0,j=0,k=0;
        arry1[k++]=n;
        ch=cin.get();
        while(ch!='\n'&&ch==' ')
        {
            cin>>n;
            arry1[k++]=n;
            ch=cin.get();
        }
        for(i=0;i<k;i++)
            cin>>arry2[i];
        Node*root=new Node;
        root->ld=NULL;
        root->rd=NULL;
        root=CreateTree(k,arry1,arry2);
        ans=100000000;
        dfs(root,0);
        cout<<pos<<endl;
        //FreeTree(root);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值