hdu 题目1800 Flying to the Mars (Hash字符串 应用)

Flying to the Mars

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8623    Accepted Submission(s): 2814


Problem Description

In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed .
For example : 
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed. 
 

Input
Input file contains multiple test cases. 
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);
 

Output
For each case, output the minimum number of broomsticks on a single line.
 

Sample Input
  
  
4 10 20 30 04 5 2 3 4 3 4
 

Sample Output
  
  
1 2
 


题目大意 

有n个人,他们的等级不同,等级高的可以交等级低的,他们可以共同用一个 broomstick,求最少用的  broomstick数目


分析: 

求最少的递增序列即可;


变相分析一下

所有的人等级 总可以排成 一个 非严格递增序列,如果允许相同的教相同的,用同一个 broomstick,

最终只需要一个,但是题目不允许 相同的等级 用同一个 broomstick。 

故设这个相同的等级人数为m,则最少需要m个 broomstick;

故 题目最终可以只求最多出现的等级数目;




/***************************
# 2013-8-29 15:06:57 
# Time: 140MS   Memory: 284K
# Author: zyh
# Status: Accepted
***************************/ 

#define MAXN 7003
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

int hash[MAXN],count[MAXN],Max;

inline int ELFhash(char *s){ //ELFHash 求字符串Hash数
    unsigned long h =0;
    unsigned long g;
    while(*s){
        h = (h<<4) + *s++;
        g = h&0xf0000000L;
        if(g)  h ^= g>>24;
        h &= ~g;
    }
    return h;
}
inline void hashit(char * s){
    int k,t;
    while(*s=='0') s++;
    k = ELFhash(s);
    t = k%MAXN;
    while( hash[t]!=k && hash[t]!=-1 )
     t = (t+10) % MAXN;
    if(hash[t]==-1) count[t] = 1,hash[t] =k;
    else if( ++ count[t]>Max) Max = count[t];
}


int main()
{
    int n;
    char s[35];
    while(scanf("%d",&n)!=EOF)
    {
        memset(hash,-1,sizeof(hash));
        Max = 1;
        while(n--){
            scanf("%s",s);
            hashit(s);
        }
        printf("%d\n",Max);
    }
    return 0;
} 




代码二:字典树处理


time :  203 MS     Memory: 19040k

#include<stdio.h>
#include<string.h>
#include<stdlib.h>


struct node{
    int cnt;
    node * child[10];
};

node * root;int Max;

void insert(char *s){
    
    int i,j;
    node *p,*q;
    q = root;
    i = 0;
    while(s[i]=='0' && i<strlen(s)-1)i++;
    
    for(;i<strlen(s);i++){
        if(q->child[s[i]-'0']) {
            q = q->child[s[i]-'0'];
        }
        else{
            p = (node *)malloc(sizeof(node));
            p->cnt=0;
            for(j=0;j<10;j++) p->child[j] = NULL;
            q->child[s[i]-'0'] = p;
            q = p;
        }
    }
    q->cnt++;
    if(Max<q->cnt) Max = q->cnt; //记录最多的出现次数

}


int main()
{
    int n,i;
    char s[35];
    while(scanf("%d",&n)!=EOF)
    {
        root = (node *)malloc(sizeof(node));
        root->cnt=0;
        for(i=0;i<10;i++) root->child[i] = NULL;
        Max = 0;
        while(n--){
            scanf("%s",s);
            insert(s);
        }    
        printf("%d\n",Max);
    }
    return 0;
} 


代码三: 求最少的递增序列的个数

time:312MS  Memory: 292K

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstdlib>

using namespace std;

int a[3001];
bool use[3001];
int main()
{
    int n,i,j,last,cnt;
    while(scanf("%d",&n)!=EOF)
    {
        memset(use,0,sizeof(use));
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        sort(a,a+n);
        
        cnt = 0;
        for(i=0;i<n;i++)
        {
            if(!use[i])
            {
                cnt++;
                use[i] = 1;
                last = a[i];
                for(j=i+1; j<n; j++)
                {
                        if(a[j]>last && !use[j])
                        {
                            use[j] =1;
                            last = a[j];    
                        }
                }    
            }    
        }
        printf("%d\n",cnt);    
    }
    //system("pause");
    return 0;    
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
YOLO高分设计资源源码,详情请查看资源内容中使用说明 YOLO高分设计资源源码,详情请查看资源内容中使用说明 YOLO高分设计资源源码,详情请查看资源内容中使用说明 YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值