HDU - 5036 Explosion

Problem Description
Everyone knows Matt enjoys playing games very much. Now, he is playing such a game. There are N rooms, each with one door. There are some keys(could be none) in each room corresponding to some doors among these N doors. Every key can open only one door. Matt has some bombs, each of which can destroy a door. He will uniformly choose a door that can not be opened with the keys in his hand to destroy when there are no doors that can be opened with keys in his hand. Now, he wants to ask you, what is the expected number of bombs he will use to open or destroy all the doors. Rooms are numbered from 1 to N.
 

Input
The first line of the input contains an integer T, denoting the number of testcases. Then T test cases follow.

In the first line of each test case, there is an integer N (N<=1000) indicating the number of rooms. 

The following N lines corresponde to the rooms from 1 to N. Each line begins with an integer k (0<=k<=N) indicating the number of keys behind the door. Then k integers follow corresponding to the rooms these keys can open.
 

Output
For each test case, output one line "Case #x: y", where x is the case number (starting from 1), y is the answer which should be rounded to 5 decimal places.
 

Sample Input
  
  
2 3 1 2 1 3 1 1 3 0 0 0
 

Sample Output
  
  
Case #1: 1.00000 Case #2: 3.00000
 

Source


题意:n个房间,每个房间都有若干个钥匙打开其他的门,如果手上没有钥匙可以选择等概率随机选择一个门炸开,求用炸弹数的期望。

思路:每个房间期望都是可加的。 单独考虑一个房间,如果有k个房间被炸开都会导致这个房间被打开。那么炸一次这个房间被打开的概率即为 kn 。也就意味着为了把这个房间打开的期望炸的次数为 nk 。全部加起来后除以n即可。bitset优化。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <bitset>
using namespace std;
const int maxn = 1005;

bitset<maxn> a[maxn];

int main() {
	int t, cas = 1;
	int n;
	scanf("%d", &t);
	while (t--) {
		scanf("%d", &n);
		for (int i = 0; i < n; i++) {
			a[i].reset();
			a[i][i] = 1;
		}

		int c, x;
		for (int i = 0; i < n; i++) {
			scanf("%d", &c);
			while (c--) {
				scanf("%d", &x);
				a[i][--x] = 1;
			}
		}

		for (int i = 0; i < n; i++)
			for (int j = 0; j < n; j++) 
				if (a[j][i])
					a[j] |= a[i];

		double ans = 0;
		for (int i = 0; i < n; i++) {
			c = 0;
			for (int j = 0; j < n; j++)
				if (a[j][i]) 
					c++;
			ans += 1.0 / c;
		}

		printf("Case #%d: %.5lf\n",cas++,ans);
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值