2012 浙大机试 Sharing

题目1468:Sharing

时间限制:1 秒

内存限制:128 兆

特殊判题:

提交:4688

解决:1001

题目描述:

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

输入:

For each case, the first line contains two addresses of nodes and a positive N (<= 10^5), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

输出:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.

样例输入:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
样例输出:
67890
-1
来源:   2012年浙江大学计算机及软件工程研究生机试真题 注意: 带前导零的读入和普通读入没差别,输出则是%0nd,n代表位数 代码:
#include <cstdio>
using namespace std;

const int maxn(1e5 + 10);
int next_pointer[maxn];
int vis[maxn];
int main()
{
    int root;
    int start1, start2, n;
    bool flag;
    int addr1, addr2;
    char v;
    int cur;
    while(scanf("%d %d %d",&start1,&start2,&n) != EOF)
    {
        root = -1;
        flag = true;
        while(n--)
        {
            scanf("%d %c %d",&addr1,&v,&addr2);
            next_pointer[addr1] = addr2;
            vis[addr1] = 0;
            if(addr2 == -1)
            {
                if(root == -1)
                    root = addr1;
                else
                    flag = false;
            }
        }
        if(flag == false)
        {
            puts("-1");
            continue;
        }
        cur = start1;
        do{
            vis[cur] = 1;
            cur = next_pointer[cur];
        }while(cur != -1);
        cur = start2;
        do{
            if(vis[cur] == 1)
            {
                printf("%05d\n",cur);
                break;
            }
            vis[cur] = 1;
            cur = next_pointer[cur];
        }while(cur != -1);
    }
    return 0;
}

                           
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值