hdu——1338——Game Prediction

Problem Description
Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game. 
Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game.

Input
The input consists of several test cases. The first line of each case contains two integers m (2 <= m <= 20) and n (1 <= n <= 50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases. 

The input is terminated by a line with two zeros.

Output
For each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game.

Sample Input
2 5
1 7 2 10 9

6 11
62 63 54 66 65 61 57 56 50 53 48

0 0
 
Sample Output
Case 1: 2

Case 2: 4

题意:

有m个人,每个人有n张卡片且没有重复的卡片,即卡片的点数是1~n*m,总共有n场比赛,每一场比赛,每个人要拿出一张卡片,若你的卡片的点数比其他人的大,则表示这一局你赢,输入n个数,表示你的卡片的点数,输出你最少能赢多少局,输入0,0时结束

思路:求出自己最多能输多少场r,n-r就是你最少能赢的场数

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std;
int vis[1005],a[60],b[1005];
int main()
{
	int n,m,i,j,k;
	int ans=0;
    while(scanf("%d%d",&m,&n)&&m+n)
    {
    	memset(vis,0,sizeof(vis));
    	for(i=0;i<n;i++)
        {
        	cin>>a[i];
        	vis[a[i]]=1;
        }
       for(i=n*m,j=0;i>0;)
       {
       	 while(vis[i])
       	 --i;
       	 b[j++]=i--;
       }
       sort(a,a+n);
       sort(b,b+n);       
       int lose=0;
       int p=n-1,q=n-1;
       for(i=0;i<n;i++)
       {
       	if(b[p]>a[q])
       	{
	       	++lose;
	       	--p;
	       	--q;
         }
         else if(b[p]<a[q])
         {
         	--q;
         }
       }
       cout<<"Case "<<++ans<<": "<<n-lose<<endl;
    }
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值