Who's in the Middle 堆排序,poj 2388

Who's in the Middle
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 28780Accepted: 16681

Description

FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less. 

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.

Input

* Line 1: A single integer N 

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.

Output

* Line 1: A single integer that is the median milk output.

Sample Input

5
2
4
1
3
5

Sample Output

3

Hint

INPUT DETAILS: 

Five cows with milk outputs of 1..5 

OUTPUT DETAILS: 

1 and 2 are below 3; 4 and 5 are above 3.

Source

 

 

 

这个题目其实想过很简单的,用sort就可以过的,但是这样实在没意思,所以我决心用堆排序来搞定,断断续续学了两天,终于会了heapsort,还是不算难的,但是数据结构我决心要学好,以后要学好数论和数据结构,成为真正的大神!!!!!!!!

 

 

#include<iostream>
#include<cstdio>
using namespace std;

void heapadjust(int a[],int i,int n)
{
    int l=2*i+1;  //i的左孩子节点
    int r=2*i; //i的右孩子节点
    int max=i;//当前设为最大值
    if(i<=n/2)//保证不是叶节点
    {
        if((l<=n)&&(a[l]>a[max]))
        {
            max=l;
        }
         if((r<=n)&&(a[r]>a[max]))
        {
            max=r;
        }
        if(max!=i)
        {
            swap(a[i],a[max]);
            heapadjust(a,max,n);//这是保证max之下仍然是一个堆
        }
    }





}


void buildheap(int a[],int n)
{
    int i;
    for(i=n/2;i>=1;i--)
    heapadjust(a,i,n);
}
void heapsort(int a[],int n)
{
    int i;
    buildheap(a,n);
    for(i=n;i>=1;i--)
    {
        swap(a[i],a[1]);//把最大的和最后一个交换,那么就保证了最后一个是最大的
        heapadjust(a,1,i-1);//需要比较的变成了i-1,数目在逐渐减小

    }

}
int main()
{

   int i,j,k,n;
   int a[10010];
   scanf("%d",&n);
   for(i=1;i<=n;i++)
   {
       scanf("%d",&a[i]);
   }
   heapsort(a,n);
   printf("%d\n",a[n/2+1]);

}



 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值