Total Amount zoj 2476

Total Amount
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Given a list of monetary amounts in a standard format, please calculate the total amount.

We define the format as follows:

1. The amount starts with '$'.

2. The amount could have a leading '0' if and only if it is less then 1.

3. The amount ends with a decimal point and exactly 2 following digits.

4. The digits to the left of the decimal point are separated into groups of three by commas (a group of one or two digits may appear on the left).


Input

The input consists of multiple tests. The first line of each test contains an integer N (1 <= N <= 10000) which indicates the number of amounts. The next N lines contain N amounts. All amounts and the total amount are between $0.00 and $20,000,000.00, inclusive. N=0 denotes the end of input.


Output

For each input test, output the total amount.


Sample Input

2
$1,234,567.89
$9,876,543.21
3
$0.01
$0.10
$1.00
0


Sample Output

$11,111,111.10
$1.11


 
这个题目其实还是挺简单的,但是我就是死活都过不了,哎,还很水啊,
如果拿到省赛上这又是水题一道了,哎,这个题目其实还是很简单的,大数累加
再用一个string的字符串求出的数字字符串和逗号和小数点,然后逆序输出就是了,
就这么简单了。还有就是一些大数累加的知识,凭此程序以后可以搞定以后的大数
累加问题了,hehe
 
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
    int temp[100];
    int ans[100];
    char ten[100];
    int i,j,n;

    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            break;
        memset(ans,0,sizeof(ans));
        int k=0;
        for(i=0; i<n; i++)
        {
            scanf("%s",ten);
            memset(temp,0,sizeof(temp));
            int l=strlen(ten);
            k=0;
            for(j=0; j<l; j++)
            {
                if((ten[l-j-1]<='9')&&(ten[l-j-1]>='0'))
                {
                    //printf("%cten",ten[j]);
                    temp[k]=ten[l-j-1]-'0';
                    //printf("%d temp",temp[k]);
                    k++;
                }

            }
            //for(i=0;i<k;i++)
            //printf("%dfdfd ",temp[i]);
            for(j=0; j<100; j++)
            {
                ans[j] = temp[j] + ans[j];
                ans[j+1] += ans[j] / 10;
                ans[j] = ans[j] % 10;
            }
        }
        for(j=0; j<100; j++)
            if(ans[100-1-j]!=0)
                break;
        int la=100-1-j;
        //printf("%d%d\n",la,k);
        la=la>=k-1 ? la : k-1;//这个适用于0.00+0.00的那些情况,在那些情况下要用k的值,而非la了
       // for(i=0; i<10; i++)
        // printf("%d",ans[j]);

        string a="";
       // printf("%dla\n",la);
        for(j=0,i=1; j<=la; j++,i++)
        {
            a+= ans[j] + 48;
            //cout<<a<<endl;
            if(j==1)
            {
                a+= ".";
                i=0;
            }
            if(i%3==0&&i!=0&&i!=la-1)
            {
                a+= ",";
            }

        }
        a+= "$";
        reverse(a.begin(), a.end());//字符串逆转
        cout<<a<<endl;





    }
    return 0;
}

 
 
 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值