Ice_cream’s world III hdu 2122 最小生成树

Ice_cream’s world III

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 658    Accepted Submission(s): 214


Problem Description
ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.
 

Input
Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.
 

Output
If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.
 

Sample Input
  
  
2 1 0 1 10 4 0
 

Sample Output
  
  
10 impossible
 

Author
Wiskey
 

Source
 

Recommend
威士忌   |   We have carefully selected several similar problems for you:   2120  2129  2118  2128  2126




套上克鲁斯卡尔模板就行了,这个无向图,是最小生成树


#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#define MAX 16005
using namespace std;
typedef struct
{
    int v1,v2,distance;
} Edge;
Edge roads[MAX+1];
int  tree[1110];
bool cmp(const Edge&a,const Edge&b)
{
    return a.distance<b.distance;
}
int Find(int x)
{
    while(x!=tree[x])
        x=tree[x];
    int u=x,v;
    while(tree[u]!=x)
    {
        v=tree[u];
        tree[u]=x;
        u=v;
    }
    return x;
}
void Union(int x,int y)
{
    int fx=Find(x),fy=Find(y);
    if(fx!=fy)
        tree[fx]=fy;
}

int main()
{
    int n,q,a,b,i,j,k,tmp,sum;
    while((scanf("%d%d",&n,&k))!=EOF)
    {
        int edge=1;
        for(i=0; i<1010; ++i)
        {
            tree[i]=i;
        }
        for(i=0;i<k;i++)
        {
            scanf("%d%d%d",&roads[i].v1,&roads[i].v2,&roads[i].distance);

        }

        sort(roads,roads+k,cmp);
        for(i=0,sum=0; i<k; ++i)
        {
            if(Find(roads[i].v1)!=Find(roads[i].v2))
            {
                edge++;
                Union(roads[i].v1,roads[i].v2);
                sum+=roads[i].distance;
            }
        }
       if(edge!=n)printf("impossible\n\n");
        else printf("%d\n\n",sum);

    }
    return 0;
}





 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值