hdu-4081-Qin Shi Huang's National Road System

Qin Shi Huang's National Road System

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3399 Accepted Submission(s): 1192


Problem Description
During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi Huang" means "the first emperor" in Chinese.

Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:
There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang.
Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people's life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads.
Would you help Qin Shi Huang?
A city can be considered as a point, and a road can be considered as a line segment connecting two points.

Input
The first line contains an integer t meaning that there are t test cases(t <= 10).
For each test case:
The first line is an integer n meaning that there are n cities(2 < n <= 1000).
Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.
It is guaranteed that each city has a distinct location.

Output
For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.

Sample Input
  
  
2 4 1 1 20 1 2 30 200 2 80 200 1 100 3 1 1 20 1 2 30 2 2 40

Sample Output
  
  
65.00 70.00
prim+次小生成树
#include<stdio.h>
#include<string.h>
#include<math.h>
#define M 0x7fffffff
#define max(a,b) a>b?a:b
int num[1002][2],mark[1002][1002];
double map[1002][1002],path[1002][1002];
int n,man[1002],que[1002];
double prim()
{
    int i,j,k,used[1002]={0};
    double sum=0.0,min,dis[1002];
    for(i=1;i<=n;i++)
    {
        dis[i]=map[1][i];
        que[i]=1;
    }
    for(i=2;i<=n;i++)
    {
        min=M;
        for(j=2;j<=n;j++)
            if(!used[j]&&min>dis[j])
        {
            k=j;
            min=dis[j];
        }
        sum+=dis[k];
        used[k]=1;
        mark[que[k]][k]=mark[k][que[k]]=1;
        for(j=1;j<=n;j++)
            if(used[j]&&j!=k)
            path[k][j]=path[j][k]=max(dis[k],path[que[k]][j]);
            else if(!used[j]&&dis[j]>map[k][j])
            {
                dis[j]=map[k][j];
                que[j]=k;
            }
    }
    return sum;
}
void result(double d)
{
    int i,j,s;
    double min=-M;
    for(i=1;i<=n;i++)
        for(j=1;j<i;j++)
        if(mark[i][j])
    {
        if(min<(man[i]+man[j])*1.0/(d-map[i][j]))
        min=(man[i]+man[j])*1.0/(d-map[i][j]);
    }
    else if(min<(man[i]+man[j])*1.0/(d-path[i][j]))
        min=(man[i]+man[j])*1.0/(d-path[i][j]);
    printf("%.2lf\n",min);
}
int main()
{
    int s,i,j;
    double d;
    scanf("%d",&s);
    while(s--)
    {
        scanf("%d",&n);
        memset(path,0,sizeof(path));
        memset(mark,0,sizeof(mark));
        for(i=1;i<=n;i++)
        {
            scanf("%d%d%d",&num[i][0],&num[i][1],&man[i]);
            map[i][i]=0.0;
            for(j=1;j<i;j++)
                map[i][j]=map[j][i]=sqrt((num[i][0]-num[j][0])*(num[i][0]-num[j][0])*1.0+(num[i][1]-num[j][1])*(num[i][1]-num[j][1])*1.0);
        }
        d=prim();
        result(d);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值