HDU3074 Multiply game 解题报告--线段树

Multiply game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1171    Accepted Submission(s): 387


Problem Description
Tired of playing computer games, alpc23 is planning to play a game on numbers. Because plus and subtraction is too easy for this gay, he wants to do some multiplication in a number sequence. After playing it a few times, he has found it is also too boring. So he plan to do a more challenge job: he wants to change several numbers in this sequence and also work out the multiplication of all the number in a subsequence of the whole sequence.
  To be a friend of this gay, you have been invented by him to play this interesting game with him. Of course, you need to work out the answers faster than him to get a free lunch, He he…

 

Input
The first line is the number of case T (T<=10).
  For each test case, the first line is the length of sequence n (n<=50000), the second line has n numbers, they are the initial n numbers of the sequence a1,a2, …,an,
Then the third line is the number of operation q (q<=50000), from the fourth line to the q+3 line are the description of the q operations. They are the one of the two forms:
0 k1 k2; you need to work out the multiplication of the subsequence from k1 to k2, inclusive. (1<=k1<=k2<=n)
1 k p; the kth number of the sequence has been change to p. (1<=k<=n)
You can assume that all the numbers before and after the replacement are no larger than 1 million.
 

Output
For each of the first operation, you need to output the answer of multiplication in each line, because the answer can be very large, so can only output the answer after mod 1000000007.
 

Sample Input
  
  
1 6 1 2 4 5 6 3 3 0 2 5 1 3 7 0 2 5
 

Sample Output
  
  
240 420
 

Source
 

Recommend
lcy
#include<iostream>
using namespace std;
#define lson L,m,rt<<1
#define rson m+1,R,rt<<1|1
__int64 sum[200000<<2];
void build(int L,int R,int rt)
{
	if (L==R)
	{
		scanf("%I64d",&sum[rt]);
		return ;
	}
	int m=(L+R)>>1;
	build(lson);
	build(rson);
	sum[rt]=sum[rt<<1]%1000000007*sum[rt<<1|1]%1000000007;
	return ;
}
void update(int p,int up,int L,int R,int rt)
{
	if (L==R)
	{
		sum[rt]=up;
		return;
	}
	int m=(L+R)>>1;
	if(p<=m) update(p,up,lson);
	if(p>m) update(p,up,rson);
	sum[rt]=sum[rt<<1]%1000000007*sum[rt<<1|1]%1000000007;
}
__int64 query(int l,int r,int L,int R,int rt)
{
	if (l<=L&&r>=R)
	{
		return sum[rt];
	}
	int m=(L+R)>>1;
	__int64 pos=1;
	if(l<=m) 
	{
		pos=pos%1000000007;
		pos*=query(l,r,lson);
	}
	if(r>m) 
	{
		pos=pos%1000000007;
		pos*=query(l,r,rson);
	}
	return pos%1000000007;
}
int main()
{
	int r;
	scanf("%d",&r);
	while (r--)
	{
		int n;
		scanf("%d",&n);
		build(1,n,1);
		int p;
		scanf("%d",&p);
		while(p--)
		{
			int a,b,c;
			scanf("%d%d%d",&a,&b,&c);
			if (a==0)
				printf("%d\n",query(b,c,1,n,1)%1000000007);
			else 
				update(b,c,1,n,1);
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值