UVA 10161 Ant on a Chessboard

 

Background

  One day, an ant called Alice came to an M*M chessboard. She wanted to go around all the grids. So she began to walk along the chessboard according to this way: (you can assume that her speed is one grid per second)

  At the first second, Alice was standing at (1,1). Firstly she went up for a grid, then a grid to the right, a grid downward. After that, she went a grid to the right, then two grids upward, and then two grids to the left…in a word, the path was like a snake.

  For example, her first 25 seconds went like this:

  ( the numbers in the grids stands for the time when she went into the grids)

 

25

24

23

22

21

10

11

12

13

20

9

8

7

14

19

2

3

6

15

18

1

4

5

16

17

5

4

3

2

1

 

1          2          3           4           5

At the 8th second , she was at (2,3), and at 20th second, she was at (5,4).

Your task is to decide where she was at a given time.

(you can assume that M is large enough)

 

 

Input

  Input file will contain several lines, and each line contains a number N(1<=N<=2*10^9), which stands for the time. The file will be ended with a line that contains a number 0.

 

 

Output

  For each input situation you should print a line with two numbers (x, y), the column and the row number, there must be only a space between them.

 

 

Sample Input

8

20

25

0

 

 

Sample Output

2 3

5 4

1 5


题意是一只蚂蚁在棋盘上爬行,给出其所在点对应的数值,求出所在位置坐标。

找规律题目,分析其路线根据行和列上的数值找出关系。

以后遇到这种题目戒骄戒躁!

代码如下:

#include <stdio.h>
#include <math.h>
int main(void)
{
    int n,t,k,x,y;
    
    while(scanf("%d",&n)&&n)
    {
     t=(int)sqrt(n);
     if(n==t*t)
     {
      if(t%2)
       printf("1 %d\n",t);
      else
       printf("%d 1\n",t);
      continue;
     }
     if(t%2)
     {
      if(n<=t*t+t+1)
      {
       x=1;y=t+1;
       for(k=t*t+1;k<=n&&x<=y;k++,x++)
        if(k==n)
        {
         printf("%d %d\n",x,y);
         break;
        }
      }
      else
      {
       x=t+1;y=t;
       for(k=t*t+t+2;k<=n&&y>=1;k++,y--)
        if(k==n)
        {
         printf("%d %d\n",x,y);
         break;     
        }
      }
     }
     else
     {
      if(n<=t*t+t+1)       
      {
       x=t+1;y=1;
       for(k=t*t+1;k<=n&&y<=x;y++,k++)
        if(k==n)
        {
         printf("%d %d\n",x,y);
         break;    
        }   
      }
      else
      {
       x=t;y=t+1;
       for(k=t*t+t+2;k<=n&&x>=1;k++,x--)
        if(k==n)
        {
         printf("%d %d\n",x,y);
         break;    
        }      
      }
     }
    } 
    return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值