关闭

idea 14提示override错误

标签: idea
347人阅读 评论(0) 收藏 举报
分类:

使用idea编写一些项目或者打开项目时,提示override错误,一般由于设置或者配置,解决如下。
1.打开 File/Project Structure,第一个Project中可对language level进行设置,采取级别6以上就行。
2.当采取上述方法不行时,继续进入刚刚目录,第二个Modules中,也有针对每个model的language level的设置,可进行设置。
3.有时候,采取maven项目编译的,设置之后,又恢复了,或者无效。原因:maven默认采取jdk 5编译了。此时,可在pom文件中指定。

    <plugin>
        <groupId>org.apache.maven.plugins</groupId>
        <artifactId>maven-compiler-plugin</artifactId>
        <version>2.3.2</version>
        <configuration>
            <source>1.7</source>
            <target>1.7</target>
        </configuration>
    </plugin>
0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:11728次
    • 积分:459
    • 等级:
    • 排名:千里之外
    • 原创:34篇
    • 转载:0篇
    • 译文:0篇
    • 评论:0条