PAT甲级真题及训练集(10)--1036. Boys vs Girls (25)

1036. Boys vs Girls (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM. If one such kind of student is missing, output "Absent" in the corresponding line, and output "NA" in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95
Sample Output 1:
Mary EE990830
Joe Math990112
6
Sample Input 2:
1
Jean M AA980920 60
Sample Output 2:
Absent
Jean AA980920
NA

提交代


/**
作者:一叶扁舟
时间:23:07 2017/6/21
思路:

*/
#include <stdio.h>
#include <stdlib.h>
#include <string.h>


int main(){
	int N; 
	char fName[20] = {0}, fId[20];//女生的名字和id
	int fScore = -1, mScore = 101;//
	char mName[20] = {0}, mId[20];
	char tempName[20], tempId[20],tempSex;
	int tempScore;

	scanf("%d", &N);
	for (int i = 0; i < N; i++){
		scanf("%s %c %s %d",tempName, &tempSex, tempId,&tempScore);
		//首先判断是男生还是女生
		if (tempSex == 'F'){//女生
			if (tempScore > fScore){//女生找到最高分
				strcpy(fName, tempName);
				strcpy(fId, tempId);
				fScore = tempScore;
			}
		}
		else{//男生
			if (tempScore < mScore){//男生找到最低分
				strcpy(mName, tempName);
				strcpy(mId, tempId);
				mScore = tempScore;
			}
		
		}
	}
	int flag = 1;
	//输出判断
	//女生信息
	if (strlen(fName) == 0){
		printf("Absent\n");
		flag = 0;
	}else{
		printf("%s %s\n", fName, fId);
	}
	//男生信息
	if (strlen(mName) == 0){
		flag = 0;
		printf("Absent\n");
	}
	else{
		printf("%s %s\n", mName, mId);
	}
	if (flag == 0){
		printf("NA\n");
	}
	else{
		printf("%d\n",(fScore - mScore));
	
	}

	system("pause");
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值