PAT甲级真题及训练集(17)--1052. Linked List Sorting (25)

1052. Linked List Sorting (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (< 105) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [-105, 105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:
5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345
Sample Output:
5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

提交代

/**
作者:一叶扁舟
时间:20:33 2017/7/1
思路:
*/
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>  
using namespace std;
#define SIZE 100001
typedef struct SList{
	int address;//地址,其对应着数组的下标
	int data;//数据域
	int next;//下一个数据的地址,对应着数组的小标
	bool flag;//如果为false,表示非法结点,用来排序使用
}SList;

//将链表以递增的顺序排序
bool comp(SList a, SList b){
	if (a.flag == false || b.flag == false){
		//只要有一个非法结点都排在后面
		return a.flag > b.flag;
	}else{
		return a.data < b.data;
	}
}
int main(){
	SList sList[SIZE];
	int address, data, next;//
	int N;//要输入的数据的长度
	int firstAddress;//链表开始的首地址jisuan
	int flag = 0;//默认恰好是分成完整的组
	//初始化让所有的结点为无效结点
	for (int i = 0; i < SIZE; i++){
		sList[i].flag  = false;
	}
	scanf("%d %d", &N, &firstAddress);
	
	//1.获取输入数据,地址对应着下标
	for (int i = 0; i < N; i++){
		scanf("%d %d %d", &address, &data, &next);
		sList[address].address = address;
		sList[address].data = data;
		sList[address].next = next;
		//小细节,不是所有的输入数据都是有效结点,因此下面的置true是错误的
		//sList[address].flag = true;
	}
	//2.将链表串起来,过滤掉一些无效数据
	int i = firstAddress;//首地址
	int count = 0;
	while (i != -1){
		sList[i].flag = true;//在链表1中出现过
		count++;
		i = sList[i].next;
	}
	if (count == 0){//链表有效结点为0时,pat测试有这个判断
		printf("0 -1\n");
		return 0;
	}
	//2.排序(从小到大的将所有数据进行排序,有数据的都排在前面)
	sort(sList, sList + SIZE, comp);
	
	//输出
	printf("%d %05d\n", count, sList[0].address);
	for (int i = 0; i < count; i++){
		if (i == count - 1){//最后一个要单独处理,因为-1无法用五位数输出格式
			printf("%05d %d -1\n", sList[i].address, sList[i].data);
			break;
		}
		printf("%05d %d %05d\n", sList[i].address, sList[i].data, sList[i+1].address);
	}
	system("pause");
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值