PAT甲级真题及训练集(20)--1086. Tree Traversals Again (25)(前序,中序建二叉树,很重要!)

1086. Tree Traversals Again (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1

提交代

/**
作者:一叶扁舟
时间:16:58 2017/7/4
思路:
说明给出一个二叉树的前序序列和中序序列,前序遍历出数据
思路,先根据前序和中序建树,然后序遍历出二叉树
可以利用手工模拟,
例子:
6
前序:  1 2 3 4 5 6
中序:  3 2 4 1 6 5
输出:
3 4 2 6 5 1
*/
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
#include <stack>
#include <queue>
#include <math.h>
#include <string.h>
#include <vector>
using namespace std;
#define SIZE 101

typedef struct Node{
	int data;
	Node * leftChild;
	Node * rightChild;
}Node;
//定义的全局变量,前序序列,中序队列
int pre[SIZE], middle[SIZE];
//定义的全局变量总共的结点数
int totalNode = 0;
int num = 0; //后序队列中已经输出的个数


/**
利用中序和前序序列递归进行建树
int preStart :前序队列起始坐标
int preEnd   :前序队列终止坐标
int midStart :中序队列起始坐标
int midEnd   :中序队列的终止坐标
*/

Node* createTree(int preStart, int preEnd, int midStart, int midEnd){
	if (preStart > preEnd){
		return NULL;
	}

	int i;
	//查找前序队列中,最前一个数据在中序队列中的位置
	for (i = midStart; i <= midEnd; i++){
		if (middle[i] == pre[preStart]){
			//找到了,中序队列中第i个位置就是的
			break;
		}

	}

	Node * root = new Node;//创建根结点(其实每一个结点都是根节点)
	//中序队列中距离的起始位置的个数,即第i个位置为根结点,左边num个是它的左子树的个数
	int numStart = i - midStart;
	root->data = pre[preStart];
	root->leftChild = createTree(preStart + 1, preStart + numStart, midStart, i - 1);
	root->rightChild = createTree(preStart + numStart + 1, preEnd, i + 1, midEnd);
	return root;
}

//后序遍历二叉树
void postOrder(Node *root){
	if (root == NULL){
		return;
	}
	postOrder(root->leftChild);
	postOrder(root->rightChild);
	printf("%d", root->data);
	num++;
	if (num < totalNode){
		printf(" ");
	}
}



int main(){
	scanf("%d", &totalNode);
	stack<int> s;
	//前序序列
	int temp;
	char tempStr[20];
	int preNum = 0;//前序的序列的下标
	int middleNum = 0;//中序序列的下标
	for (int i = 0; i < totalNode * 2; i++){
		scanf("%s",tempStr);
		if (strcmp(tempStr,"Push") == 0){
			scanf("%d", &temp);
			pre[preNum] = temp;
			//进栈队列即为前序序列
			preNum++;
			s.push(temp);
		}
		else{
		//出队顺序即为中序序列
			middle[middleNum] = s.top();
			middleNum++;
			s.pop();
		
		}
	
	
	}

	//根据前序和中序序列建二叉树
	Node* root = createTree(0, totalNode - 1, 0, totalNode - 1);
	//后序遍历
	postOrder(root);

	system("pause");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值