POJ2909_Goldbach's Conjecture【素数判断】【水题】

Goldbach's Conjecture
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10116 Accepted: 5973
Description


For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that


n = p1 + p2


This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.


A sequence of even numbers is given as input. There can be many such numbers. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.


Input


An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 215. The end of the input is indicated by a number 0.


Output


Each output line should contain an integer number. No other characters should appear in the output.


Sample Input


6
10
12
0
Sample Output


1
2
1
Source


Svenskt Mästerskap i Programmering/Norgesmesterskapet 2002

题目大意:给出一个偶数,要求在这个偶数的范围内,有几对素数和是等于这个偶数的

注意素数对的不重复性!   比如 n = a + b(a,b为素数) 则n = b + a 就重复了

思路:只需要枚举2到n/2的数i,判断i和n-i是否都为素数,并计数就可以了

#include<stdio.h>

int Prime[1000010];
void IsPrime()
{
    for(int i = 2; i <= 1000000; i++)
        Prime[i] = 1;
    for(int i = 2; i <= 1000000; i++)
    {
        if(Prime[i])
        {
           for(int j = i+i; j <= 1000000; j+=i)
           {
               Prime[j] = 0;
           }
        }

    }
}

int main()
{
    int n;
    IsPrime();
    while(~scanf("%d",&n) && n)
    {
        int num = 0;
        for(int i = 2; i <=n/2; i++)
        {
            if(Prime[i] && Prime[n-i])
            {
                num++;
            }
        }
        printf("%d\n",num);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值