HDU1718 Rank【水题】

Rank


Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3980    Accepted Submission(s): 1539

Problem Description
Jackson wants to know his rank in the class. The professor has posted a list of student numbers and marks. Compute Jackson’s rank in class; that is, if he has the top mark(or is tied for the top mark) his rank is 1; if he has the second best mark(or is tied) his rank is 2, and so on.
 
Input
The input consist of several test cases. Each case begins with the student number of Jackson, an integer between 10000000 and 99999999. Following the student number are several lines, each containing a student number between 10000000 and 99999999 and a mark between 0 and 100. A line with a student number and mark of 0 terminates each test case. There are no more than 1000 students in the class, and each has a unique student number.
 
Output
For each test case, output a line giving Jackson’s rank in the class.
 
Sample Input
20070101
20070102 100
20070101 33
20070103 22
20070106 33
0 0
 
Sample Output

2


题目大意:第一行是Jackson的学号,之后是Jackson及班里同学的学号、分数。

问:Jackson在班里是第几。

思路:有一点会出错。假如有和Jackson分数一样的同学,Jackson的排名和他

们是并列排名,而不是字典序递增排名。


#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;

struct Node
{
    int id;
    int score;
};

Node A[1100];

int cmp(Node a,Node b)
{
    if(a.score != b.score)
        return a.score > b.score;
    return a.id < b.id;
}

int main()
{
    int id;
    while(cin >> id)
    {
        int i = 0;
        memset(A,0,sizeof(A));
        while(cin >> A[i].id >> A[i].score)
        {
            if(A[i].id==0 && A[i].score==0)
                break;
            i++;
        }
        sort(A,A+i,cmp);
        //cout << i << endl;
        int rank = 0;
        for(int j = 0; j < i; j++)
            if(A[j].id == id)
            {
                int k = j-1;
                while(A[k].score == A[j].score && k >= 0)
                {
                    k--;
                    rank--;
                }
                cout << rank+1 << endl;
            }

            else
                rank++;
    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值