HDU2088 Box of Bricks【水题】

Box of Bricks


Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11899    Accepted Submission(s): 4014

Problem Description

Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. “Look, I've built a wall!”, he tells his older sister Alice. “Nah, you should make all stacks the same height. Then you would have a real wall.”, she retorts. After a little consideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?


Input
The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1≤n≤50 and 1≤hi≤100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.
 
Output
For each set, print the minimum number of bricks that have to be moved in order to make all the stacks the same height.
Output a blank line between each set.
 
Sample Input
6
5 2 4 1 7 5
0
 
Sample Output
5
 
Author
qianneng
 
Source

冬练三九之二


题目大意:给你N堆砖的高度,通过移动,使得这N堆砖变得一样高,问最少移动

多少块砖。

思路:先求出变得一样高的高度(平均高度),再遍历一遍高度,低于平均高度的砖

与平均高度相差的高度差的总和就是所求结果。


#include<iostream>
#include<algorithm>
using namespace std;

int main()
{
    int N,a[55],ok = 0;
    while(cin >> N && N!=0)
    {
        if(ok == 0)
            ok = 1;
        else
            cout << endl;
        int Sum = 0;
        for(int i = 0; i < N; ++i)
        {
            cin >> a[i];
            Sum += a[i];
        }
        Sum /= N;
        int ans = 0;
        for(int i = 0; i < N; ++i)
        {
            if(a[i] < Sum)
                ans += (Sum-a[i]);
        }
        cout << ans << endl;
    }

    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值