【PAT】【Advanced Level】1017. Queueing at Bank (25)

1017. Queueing at Bank (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:
8.2

原题链接:

https://www.patest.cn/contests/pat-a-practise/1017

https://www.nowcoder.com/questionTerminal/e15d6a86f9ef4c43ae3a286196c3b5da

思路:

模拟

坑点:

等待时间截止到开始办理

17点之后的处理

CODE:

#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<algorithm>
#define N 10010
#define K 110
using namespace std;

typedef struct S
{
  string t;
  int tt;
  int p;
  int wa;
};
typedef struct T
{
  int num;
  int rest;
};
S pas[N];
T ser[K];

bool cmp(S a, S b)
{
    return a.t<b.t;
}


int main()
{
    int n,k;
    cin>>n>>k;
    for (int i=0;i<n;i++)
    {
        cin>>pas[i].t>>pas[i].p;
        pas[i].tt=atoi(pas[i].t.substr(0,2).c_str())*3600+atoi(pas[i].t.substr(3,2).c_str())*60+atoi(pas[i].t.substr(6,2).c_str());
        pas[i].tt-=3600*8;
        pas[i].p*=60;
    }
    sort(pas,pas+n,cmp);
    //for (int i=0;i<n;i++)cout<<pas[i].t<<" "<<pas[i].p<<" "<<pas[i].tt<<endl;
    int no=0;
    for (int i=0;i<k;i++)
    {
        if (no==n) break;
        if (pas[no].t>"08:00:00") break;
        pas[no].wa=0;
        ser[i].num=no;
        ser[i].rest=pas[no].p;
        no++;
    }
    for (int i=1;i<=540*60;i++)
    {
        for (int j=0;j<k;j++)
        {
            if (ser[j].rest==0)
            {
                if (no==n) continue;
                if (pas[no].tt>i) continue;
                ser[j].rest=pas[no].p;
                ser[j].num=no;
                pas[no].wa=i;
                no++;
                continue;
            }
            ser[j].rest--;
            if (ser[j].rest==0)
            {
                if (no==n) continue;
                if (pas[no].tt>i) continue;
                ser[j].rest=pas[no].p;
                ser[j].num=no;
                pas[no].wa=i;
                no++;
            }
        }
    }
    int mm=0;
    for (int i=0;i<k;i++)
    {
        if (ser[i].rest>mm) mm=ser[i].rest;
    }
    for (int i=540*60+0;i<540*60+mm;i++)
    {
        for (int j=0;j<k;j++)
        {
            if (ser[j].rest==0)
            {
                if (no==n) continue;
                if (pas[no].tt>3600*9) continue;
                mm=max(mm,i+pas[no].p);
                ser[j].rest=pas[no].p;
                ser[j].num=no;
                pas[no].wa=i;
                no++;
                continue;
            }
            ser[j].rest--;
            if (ser[j].rest==0)
            {
                if (no==n) continue;
                if (pas[no].tt>3600*9) continue;
                mm=max(mm,i+pas[no].p);
                ser[j].rest=pas[no].p;
                ser[j].num=no;
                pas[no].wa=i;
                no++;
                continue;
            }
        }
    }
    //cout<<no<<" "<<n<<endl;
    int ree=0;
    for (int i=0;i<no;i++)
    {

        //cout<<(pas[i].wa-pas[i].tt)/60<<endl;
        ree+=(pas[i].wa-pas[i].tt);
    }
    double ress=ree/(60.0*no);
    printf("%.1f",ress);
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值