hdu 1415 Jugs(BFS)

Jugs

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 797    Accepted Submission(s): 263


Problem Description
In the movie "Die Hard 3", Bruce Willis and Samuel L. Jackson were confronted with the following puzzle. They were given a 3-gallon jug and a 5-gallon jug and were asked to fill the 5-gallon jug with exactly 4 gallons. This problem generalizes that puzzle. 

You have two jugs, A and B, and an infinite supply of water. There are three types of actions that you can use: (1) you can fill a jug, (2) you can empty a jug, and (3) you can pour from one jug to the other. Pouring from one jug to the other stops when the first jug is empty or the second jug is full, whichever comes first. For example, if A has 5 gallons and B has 6 gallons and a capacity of 8, then pouring from A to B leaves B full and 3 gallons in A. 

A problem is given by a triple (Ca,Cb,N), where Ca and Cb are the capacities of the jugs A and B, respectively, and N is the goal. A solution is a sequence of steps that leaves exactly N gallons in jug B. The possible steps are 

fill A 
fill B 
empty A 
empty B 
pour A B 
pour B A 
success 

where "pour A B" means "pour the contents of jug A into jug B", and "success" means that the goal has been accomplished. 

You may assume that the input you are given does have a solution. 

 

Input
Input to your program consists of a series of input lines each defining one puzzle. Input for each puzzle is a single line of three positive integers: Ca, Cb, and N. Ca and Cb are the capacities of jugs A and B, and N is the goal. You can assume 0 < Ca <= Cb and N <= Cb <=1000 and that A and B are relatively prime to one another. 

 

Output
Output from your program will consist of a series of instructions from the list of the potential output lines which will result in either of the jugs containing exactly N gallons of water. The last line of output for each puzzle should be the line "success". Output lines start in column 1 and there should be no empty lines nor any trailing spaces. 

 

Sample Input
  
  
3 5 4 5 7 3
 

Sample Output
  
  
fill B pour B A empty A pour B A fill B pour B A success fill A pour A B fill A pour A B empty B pour A B success
#include <iostream>
#include <cstdio>
#include <vector>
#include <queue>
using namespace std;

const int maxn = 1010;
struct point{
    int A , B;
    point(int a = 0 , int b = 0){
        A = a , B = b;
    }
};
string ans[maxn][maxn];
int vis[maxn][maxn];
string op[6] = {"fill B" , "fill A" , "empty A" , "empty B" , "pour B A" , "pour A B"};
int Ca , Cb , N;

void initial(){
    for(int i = 0; i < maxn; i++){
        for(int j = 0; j < maxn; j++){
            vis[i][j] = 0;
            ans[i][j].clear();
        }
    }
}

void computing(){
    queue<point> q;
    q.push(point(0 , 0));
    while(!q.empty()){
        point jug = q.front();
        q.pop();
        //cout << jug.B << " " << Cb << endl;
        if(jug.B == N){
            for(int i = 0; i < ans[jug.A][jug.B].length(); i++){
                cout << op[ans[jug.A][jug.B][i]-'0'] << endl;
            }
            cout << "success" << endl;
            break;
        }
        if(jug.B < Cb && vis[jug.A][Cb] == 0){
            vis[jug.A][Cb] = 1;
            ans[jug.A][Cb] = ans[jug.A][jug.B];
            ans[jug.A][Cb].push_back('0');
            q.push(point(jug.A , Cb));
        }
        if(jug.A < Ca && vis[Ca][jug.B] == 0){
            vis[Ca][jug.B] = 1;
            ans[Ca][jug.B] = ans[jug.A][jug.B];
            ans[Ca][jug.B].push_back('1');
            q.push(point(Ca , jug.B));
        }
        if(jug.A != 0 && vis[0][jug.B] == 0){
            vis[0][jug.B] = 1;
            ans[0][jug.B] = ans[jug.A][jug.B];
            ans[0][jug.B].push_back('2');
            q.push(point(0 , jug.B));
        }
        if(jug.B != 0 && vis[jug.A][0] == 0){
            vis[jug.A][0] = 1;
            ans[jug.A][0] = ans[jug.A][jug.B];
            ans[jug.A][0].push_back('3');
            q.push(point(jug.A , 0));
        }
        if(jug.A != Ca){
            if(Ca-jug.A >= jug.B && vis[jug.A+jug.B][0] == 0){
                vis[jug.A+jug.B][0] = 1;
                ans[jug.A+jug.B][0] = ans[jug.A][jug.B];
                ans[jug.A+jug.B][0].push_back('4');
                q.push(point(jug.A+jug.B , 0));
            }else if(Ca-jug.A < jug.B && vis[Ca][jug.A+jug.B-Ca] == 0){
                vis[Ca][jug.A+jug.B-Ca] = 1;
                ans[Ca][jug.A+jug.B-Ca] = ans[jug.A][jug.B];
                ans[Ca][jug.A+jug.B-Ca].push_back('4');
                q.push(point(Ca , jug.A+jug.B-Ca));
            }
        }
        if(jug.B != Cb){
            if(Cb-jug.B >= jug.A && vis[0][jug.A+jug.B] == 0){
                vis[0][jug.A+jug.B] = 1;
                ans[0][jug.A+jug.B] = ans[jug.A][jug.B];
                ans[0][jug.A+jug.B].push_back('5');
                q.push(point(0 , jug.A+jug.B));
            }else if(Cb-jug.B < jug.A && vis[jug.A+jug.B-Cb][Cb] == 0){
                vis[jug.A+jug.B-Cb][Cb] = 1;
                ans[jug.A+jug.B-Cb][Cb] = ans[jug.A][jug.B];
                ans[jug.A+jug.B-Cb][Cb].push_back('5');
                q.push(point(jug.A+jug.B-Cb , Cb));
            }
        }
    }
}

int main(){
    while(scanf("%d%d%d" , &Ca , &Cb , &N) != EOF){
        initial();
        computing();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值