[HDU 2222] Keywords Search (AC自动机)

Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc. 
Wiskey also wants to bring this feature to his image retrieval system. 
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched. 
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match. 
 
Input
First line will contain one integer means how many cases will follow by. 
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000) 
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50. 
The last line is the description, and the length will be not longer than 1000000. 
 
Output
Print how many keywords are contained in the description.
 
Sample Input
1
5
she
he
say
shr
her
yasherhs 
 
Sample Output

3


给定若干个模板串和一个母串,求有多少个模板能在母串中匹配。AC自动机的裸题。

AC自动机中的精髓:

(1)fail指针(重要):由于一个串可能会包含另一个串,所以trie树上的非结尾点也可能是另一个单词的结尾。所以即使val==0的点也要fail 一下判断他是不是另一个单词的节点。

(2)fail的优化:用last 表示顺着fail回去能找到的第一个单词结尾。

(3)trie的优化(重要):对于不存在的nxt[ i ] ,存储它可能的fail。以节省在匹配的时候反复fail的时间。因为这个节点不存在,匹配到他的时候肯定失配了。 trie[ np ].nxt[ i ] = trie[ fap ].nxt[ i ]; 所以匹配的时候就不用while一下找fail了, 直接读这个点,若不存在,里边存的就是可能的fail。np = trie[ np ].nxt[ chn ]; 


这题也存在一些坑点:

(1)相同的字符串可能重复出现,最后计数的时候要按照不同的字符串处理。

(2)沿着fail 回去把那些val 累加起来后,别忘了清零,以防重复计数。


#include <cstdio>
#include <cstdlib>
#include <cstring>

using namespace std;
const int noden = 10000*50+1000, inptn = 1000000+100;

int chnum(char a){return a-'a';}

struct trnode
{
	char chr;
	int nxt[28];
	int fail;
	int last;
	int val;
};

int n;
char inpt[inptn];
trnode trie[noden];
int triep;

int que[noden];

void addstr(char*);
void calfail();

int main()
{
	int T;
	scanf("%d", &T);
	while(T--)
	{
		scanf("%d", &n);
		triep = 0;
		memset(trie, 0, sizeof(trie));
		while(n--)
		{
			char patn[80];
			scanf("%s", patn);
			addstr(patn);
		}
		calfail();
		
		scanf("%s", inpt);
		int ilen = strlen(inpt);
		int np = 0;
		int ans = 0;
		
		for(int i=0; i<ilen; i++)
		{
			int chn = chnum(inpt[i]);
			np = trie[np].nxt[chn];
			if(trie[np].val)
			{
				ans += trie[np].val;
				trie[np].val = 0;
			}
			int temp = trie[np].last;
			while(temp && trie[temp].val)
			{
				ans += trie[temp].val;
				trie[temp].val = 0;
				temp = trie[temp].last;
			}
			
		}
		
		printf("%d\n", ans);
		
	}
	return 0;
}

void addstr( char *patn )
{
	int plen = strlen(patn);
	int np = 0;
	for(int i=0; i<plen; i++)
	{
		if( trie[np].nxt[chnum(patn[i])] )
		{
			np = trie[np].nxt[ chnum(patn[i]) ];
 		}
 		else
 		{
			triep++;
			trie[np].nxt[ chnum(patn[i]) ] = triep;
			np = triep;
			trie[np].chr = patn[i];
		}
		if(i == plen-1) trie[np].val ++;
	}
	return;
}

void calfail()
{
	int qhead=0, qtail=0;

	for(int i=0; i<26; i++)
	{
		int nxp = trie[0].nxt[i];
		if(nxp)
			que[++qtail] = nxp;
	}
	
	while(qhead<qtail)
	{
		int np = que[++qhead];
		for(int i=0; i<26; i++)
		{
			int nxp = trie[np].nxt[i];
			int fap = trie[np].fail;
			if(!nxp)
			{
				trie[np].nxt[i] = trie[fap].nxt[i];
				continue;
			}
			que[++qtail] = nxp;
			trie[nxp].fail = trie[fap].nxt[i];
			fap = trie[nxp].fail;
			trie[nxp].last = trie[fap].val ? fap: trie[fap].last;
		}
	}
	return;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值