STS Eclipse IDEA 指定启动JDK版本

原创 2017年01月03日 16:35:22

使用场景:

开发人员在自己的机器上可能装了多个版本的JDK,但是在环境变量中只能配置一个 JAVA_HOME ,so你的IDEA Eclipse 可能因为你在 JAVA_HOME 配置JDK1.8 以下的版本而无法启动(这个问题在新版本的IDEA Eclipse 中十分常见),所以下面的方法你值得拥有。

1、STS Eclipse 指定启动JDK版本

  • 通过修改 STS.ini 或者 Eclipse.ini 文件第一行(必须是第一行)添加如下内容:

    -vm
    D:/software/java/jdk1.8.0_73/bin/javaw

2、IDEA 指定启动JDK版本

说明:IDEA 16 版本的64.exe 启动必须要 jdk1.8 环境(为什么要用64.exe呢?因为64默认内存更大,稳定性更好),但是你在JAVA_HOME中配置的 <1.8 ,怎么解决这个问题呢?看下面:

  • 在环境变量中添加 IDEA_JDK配置JDK1.8 , 然后通过idea.bat文件启动IDEA,问题解决!
版权声明:本文为博主原创文章,未经博主允许不得转载。

相关文章推荐

应为本机上的jdk版本低导致spring-tool-suite无法启动

前提: 编译器版本:spring-tool-suite-3.7.0.RELEASE-e4.5-win32-x86_64 本机jdk(环境变量配置):1.6 问题日志:!SESSION 2...

STS(Spring tool suite) JAVA开发环境搭建

使用 STS 开发环境有一段时间了,总体感觉比当时用原生态的 Eclipse 好不少。个人总结可以主要有一些两个方面的原因。 个人JAVA开发环境的搭建能力有所提升,从认知和思想上日趋...

STS指定IDE使用JDK

貌似以下问题解决方案也适用于Eclipse 常见问题: 一、 Version 1.7.0_79 of the JVM is not suitable for this product. Versi...

IntelliJ IDEA必须使用最新jdk问题解决

最近碰见一个问题,公司的项目大部分是jdk1.7的,然后下了最新的IntelliJ IDEA居然需要1.8才能启动,这就尴尬了。难道要改java_home?上网搜了下,在一个评论区找到了答案,现在整理...

spring-tool-suite启动时指定使用jre

spring-tool-suite 在启动时候需要使用jre1.7, 但是本地环境变量用的是jre1.6,还不能修改此环境变量,因为别的软件要使用jre1.6。 此时,就需要新建一个快捷方式:C:...

IntelliJ IDEA 中如何配置多个jdk版本即(1.7和1.8两个jdk都可用)

有时候需要看Java源码,但是 Java 1.7 和 Java 1.8的差别的关系,有时候你想查看不同jdk版本的Java源码。 或者你的项目需要测试不同Java jdk 版本的通用与否。那么这个编辑...

启动64位IDEA2016版本需要Java JDK 1.8版本,开发环境JDK 1.7问题解决方案(新增linux下配置)

向来废话不多说,好多同学想必遇到 IDEA64位启动需要Java1.8的情况,但是咱们环境用Java1.8的的确不多。那么该如何解决呢?本人通过阅读IDEA的帮助文档找到了答案!!! 如下图: 写的清...

解决jdk版本问题导致eclipse/myeclipse启动出错

启动myeclipse后提示一下错误 unsupporte major.minor vesioin 51.0。。。 问题是eclipse的编辑jdk版本不对。 解决方法 右键--》(1)p...

Idea 中JDK版本设置问题导致ClassNotFoundException错误的一种原因

今天在使用Idea编写代码测试时,点击Run之后,一直报错ClassNotFoundException,就连最简单的Hello world程序都是如此,一时之间,不知所措。Baidu、Google了一...

Android开发环境搭建全程演示(jdk+eclipse+android sdk包含版本更新)

一 相关下载(1) java JDK下载:进入该网页: http://java.sun.com/javase/downloads/index.jsp (或者直接点击下载)如下图:选择 Download...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:深度学习:神经网络中的前向传播和反向传播算法推导
举报原因:
原因补充:

(最多只允许输入30个字)