POJ1149

PIGS
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 17531 Accepted: 7947

Description

Mirko works on a pig farm that consists of M locked pig-houses and Mirko can't unlock any pighouse because he doesn't have the keys. Customers come to the farm one after another. Each of them has keys to some pig-houses and wants to buy a certain number of pigs. 
All data concerning customers planning to visit the farm on that particular day are available to Mirko early in the morning so that he can make a sales-plan in order to maximize the number of pigs sold. 
More precisely, the procedure is as following: the customer arrives, opens all pig-houses to which he has the key, Mirko sells a certain number of pigs from all the unlocked pig-houses to him, and, if Mirko wants, he can redistribute the remaining pigs across the unlocked pig-houses. 
An unlimited number of pigs can be placed in every pig-house. 
Write a program that will find the maximum number of pigs that he can sell on that day.

Input

The first line of input contains two integers M and N, 1 <= M <= 1000, 1 <= N <= 100, number of pighouses and number of customers. Pig houses are numbered from 1 to M and customers are numbered from 1 to N. 
The next line contains M integeres, for each pig-house initial number of pigs. The number of pigs in each pig-house is greater or equal to 0 and less or equal to 1000. 
The next N lines contains records about the customers in the following form ( record about the i-th customer is written in the (i+2)-th line): 
A K1 K2 ... KA B It means that this customer has key to the pig-houses marked with the numbers K1, K2, ..., KA (sorted nondecreasingly ) and that he wants to buy B pigs. Numbers A and B can be equal to 0.

Output

The first and only line of the output should contain the number of sold pigs.

Sample Input

3 3
3 1 10
2 1 2 2
2 1 3 3
1 2 6

Sample Output

7


合并点 + 最大流

题目大意如下:

给出M个猪圈,一开始每个猪圈有若干只猪,猪圈是上锁的。依次有N个顾客,他们分别有某些猪圈的钥匙,且最多购买若干头猪,他们会暂时打开猪圈,此时可以任意移动打开猪圈里的猪,问最多可以卖出去多少头猪?

很容易地我们可以得出以下网络:



但是该网络至少拥有M ^ 2个点,可能会超时,我们考虑用如下规律将网络简化:


于是可以得到下面的网络:



总结出我们按照以下规则构图:




该网络的最大流,即本题的答案。


代码如下:

/* 
* @Author: duyixian
* @Date:   2015-04-21 11:43:49
* @Last Modified by:   duyixian
* @Last Modified time: 2015-04-21 16:02:26
*/

#include "cstdio"
#include "cstdlib"
#include "iostream"
#include "algorithm"
#include "queue"
#include "cstring"

using namespace std;

#define MAX_SIZE 1005
#define INF 0x3F3F3F3F

int Map[MAX_SIZE][MAX_SIZE], Before[MAX_SIZE], Begin[MAX_SIZE], Distance[MAX_SIZE];
int N, M, S, T;

bool BFS()
{
	memset(Distance, 0, sizeof(Distance));
	Distance[S] = 1;
	queue<int> Queue;
	Queue.push(S);
	while(!Queue.empty())
	{
		int Now = Queue.front();
		Queue.pop();
		for(int i = S; i <= T; ++i)
			if(!Distance[i] && Map[Now][i])
			{
				Distance[i] = Distance[Now] + 1;
				Queue.push(i);
			}
	}
	return Distance[T];
}

int DFS(int Now, int In)
{
	if(Now == T)
		return In;
	int Rest = In;
	for(int i = S; i <= T; ++i)
		if(Map[Now][i] && Distance[i] == Distance[Now] + 1)
		{
			int Increment;
			Increment = DFS(i, min(Rest, Map[Now][i]));
			Rest -= Increment;
			Map[Now][i] -= Increment;
			Map[i][Now] += Increment;
			if(!Rest)
				return In;
		}
	if(Rest == In)
		Distance[Now] = 0;
	return In - Rest;
}

int Max_Flow()
{
	int Ans = 0;
	while(BFS())
	{
		Ans += DFS(S, INF);
	}
	return Ans;
}

int main()
{
	freopen("input.txt", "r", stdin);
	freopen("output.txt", "w",stdout);
	cin >> M >> N;
	S = 0;
	T = N + 1;
	for(int i = 1; i <= M; ++i)
		scanf("%d", &Begin[i]);
	for(int i = 1; i <= N; ++i)
	{
		int temp, temp1;
		scanf("%d", &temp);
		for(int j = 1; j <= temp; ++j)
		{
			scanf("%d", &temp1);
			if(Before[temp1] == S)
			{
				Map[S][i] += Begin[temp1];
				Before[temp1] = i;
			}
			else
			{
				Map[Before[temp1]][i] = INF;
				Before[temp1] = i;
			}
		}
		scanf("%d", &temp);
		Map[i][T] = temp;
	}
	cout << Max_Flow() << endl;
	fclose(stdout);
	fclose(stdin);
	return 0;
}
引用资料:

http://wenku.baidu.com/view/0ad00abec77da26925c5b01c.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值