POJ1149

PIGS
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 17531 Accepted: 7947

Description

Mirko works on a pig farm that consists of M locked pig-houses and Mirko can't unlock any pighouse because he doesn't have the keys. Customers come to the farm one after another. Each of them has keys to some pig-houses and wants to buy a certain number of pigs. 
All data concerning customers planning to visit the farm on that particular day are available to Mirko early in the morning so that he can make a sales-plan in order to maximize the number of pigs sold. 
More precisely, the procedure is as following: the customer arrives, opens all pig-houses to which he has the key, Mirko sells a certain number of pigs from all the unlocked pig-houses to him, and, if Mirko wants, he can redistribute the remaining pigs across the unlocked pig-houses. 
An unlimited number of pigs can be placed in every pig-house. 
Write a program that will find the maximum number of pigs that he can sell on that day.

Input

The first line of input contains two integers M and N, 1 <= M <= 1000, 1 <= N <= 100, number of pighouses and number of customers. Pig houses are numbered from 1 to M and customers are numbered from 1 to N. 
The next line contains M integeres, for each pig-house initial number of pigs. The number of pigs in each pig-house is greater or equal to 0 and less or equal to 1000. 
The next N lines contains records about the customers in the following form ( record about the i-th customer is written in the (i+2)-th line): 
A K1 K2 ... KA B It means that this customer has key to the pig-houses marked with the numbers K1, K2, ..., KA (sorted nondecreasingly ) and that he wants to buy B pigs. Numbers A and B can be equal to 0.

Output

The first and only line of the output should contain the number of sold pigs.

Sample Input

3 3
3 1 10
2 1 2 2
2 1 3 3
1 2 6

Sample Output

7


合并点 + 最大流

题目大意如下:

给出M个猪圈,一开始每个猪圈有若干只猪,猪圈是上锁的。依次有N个顾客,他们分别有某些猪圈的钥匙,且最多购买若干头猪,他们会暂时打开猪圈,此时可以任意移动打开猪圈里的猪,问最多可以卖出去多少头猪?

很容易地我们可以得出以下网络:



但是该网络至少拥有M ^ 2个点,可能会超时,我们考虑用如下规律将网络简化:


于是可以得到下面的网络:



总结出我们按照以下规则构图:




该网络的最大流,即本题的答案。


代码如下:

/* 
* @Author: duyixian
* @Date:   2015-04-21 11:43:49
* @Last Modified by:   duyixian
* @Last Modified time: 2015-04-21 16:02:26
*/

#include "cstdio"
#include "cstdlib"
#include "iostream"
#include "algorithm"
#include "queue"
#include "cstring"

using namespace std;

#define MAX_SIZE 1005
#define INF 0x3F3F3F3F

int Map[MAX_SIZE][MAX_SIZE], Before[MAX_SIZE], Begin[MAX_SIZE], Distance[MAX_SIZE];
int N, M, S, T;

bool BFS()
{
	memset(Distance, 0, sizeof(Distance));
	Distance[S] = 1;
	queue<int> Queue;
	Queue.push(S);
	while(!Queue.empty())
	{
		int Now = Queue.front();
		Queue.pop();
		for(int i = S; i <= T; ++i)
			if(!Distance[i] && Map[Now][i])
			{
				Distance[i] = Distance[Now] + 1;
				Queue.push(i);
			}
	}
	return Distance[T];
}

int DFS(int Now, int In)
{
	if(Now == T)
		return In;
	int Rest = In;
	for(int i = S; i <= T; ++i)
		if(Map[Now][i] && Distance[i] == Distance[Now] + 1)
		{
			int Increment;
			Increment = DFS(i, min(Rest, Map[Now][i]));
			Rest -= Increment;
			Map[Now][i] -= Increment;
			Map[i][Now] += Increment;
			if(!Rest)
				return In;
		}
	if(Rest == In)
		Distance[Now] = 0;
	return In - Rest;
}

int Max_Flow()
{
	int Ans = 0;
	while(BFS())
	{
		Ans += DFS(S, INF);
	}
	return Ans;
}

int main()
{
	freopen("input.txt", "r", stdin);
	freopen("output.txt", "w",stdout);
	cin >> M >> N;
	S = 0;
	T = N + 1;
	for(int i = 1; i <= M; ++i)
		scanf("%d", &Begin[i]);
	for(int i = 1; i <= N; ++i)
	{
		int temp, temp1;
		scanf("%d", &temp);
		for(int j = 1; j <= temp; ++j)
		{
			scanf("%d", &temp1);
			if(Before[temp1] == S)
			{
				Map[S][i] += Begin[temp1];
				Before[temp1] = i;
			}
			else
			{
				Map[Before[temp1]][i] = INF;
				Before[temp1] = i;
			}
		}
		scanf("%d", &temp);
		Map[i][T] = temp;
	}
	cout << Max_Flow() << endl;
	fclose(stdout);
	fclose(stdin);
	return 0;
}
引用资料:

http://wenku.baidu.com/view/0ad00abec77da26925c5b01c.html

在使用Python来安装geopandas包时,由于geopandas依赖于几个其他的Python库(如GDAL, Fiona, Pyproj, Shapely等),因此安装过程可能需要一些额外的步骤。以下是一个基本的安装指南,适用于大多数用户: 使用pip安装 确保Python和pip已安装: 首先,确保你的计算机上已安装了Python和pip。pip是Python的包管理工具,用于安装和管理Python包。 安装依赖库: 由于geopandas依赖于GDAL, Fiona, Pyproj, Shapely等库,你可能需要先安装这些库。通常,你可以通过pip直接安装这些库,但有时候可能需要从其他源下载预编译的二进制包(wheel文件),特别是GDAL和Fiona,因为它们可能包含一些系统级的依赖。 bash pip install GDAL Fiona Pyproj Shapely 注意:在某些系统上,直接使用pip安装GDAL和Fiona可能会遇到问题,因为它们需要编译一些C/C++代码。如果遇到问题,你可以考虑使用conda(一个Python包、依赖和环境管理器)来安装这些库,或者从Unofficial Windows Binaries for Python Extension Packages这样的网站下载预编译的wheel文件。 安装geopandas: 在安装了所有依赖库之后,你可以使用pip来安装geopandas。 bash pip install geopandas 使用conda安装 如果你正在使用conda作为你的Python包管理器,那么安装geopandas和它的依赖可能会更简单一些。 创建一个新的conda环境(可选,但推荐): bash conda create -n geoenv python=3.x anaconda conda activate geoenv 其中3.x是你希望使用的Python版本。 安装geopandas: 使用conda-forge频道来安装geopandas,因为它提供了许多地理空间相关的包。 bash conda install -c conda-forge geopandas 这条命令会自动安装geopandas及其所有依赖。 注意事项 如果你在安装过程中遇到任何问题,比如编译错误或依赖问题,请检查你的Python版本和pip/conda的版本是否是最新的,或者尝试在不同的环境中安装。 某些库(如GDAL)可能需要额外的系统级依赖,如地理空间库(如PROJ和GEOS)。这些依赖可能需要单独安装,具体取决于你的操作系统。 如果你在Windows上遇到问题,并且pip安装失败,尝试从Unofficial Windows Binaries for Python Extension Packages网站下载相应的wheel文件,并使用pip进行安装。 脚本示例 虽然你的问题主要是关于如何安装geopandas,但如果你想要一个Python脚本来重命名文件夹下的文件,在原始名字前面加上字符串"geopandas",以下是一个简单的示例: python import os # 指定文件夹路径 folder_path = 'path/to/your/folder' # 遍历文件夹中的文件 for filename in os.listdir(folder_path): # 构造原始文件路径 old_file_path = os.path.join(folder_path, filename) # 构造新文件名 new_filename = 'geopandas_' + filename # 构造新文件路径 new_file_path = os.path.join(folder_path, new_filename) # 重命名文件 os.rename(old_file_path, new_file_path) print(f'Renamed "{filename}" to "{new_filename}"') 请确保将'path/to/your/folder'替换为你想要重命名文件的实际文件夹路径。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值