poj 3083 Children of the Candy Corn dfs+bfs

Description

The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find the exit.

One popular maze-walking strategy guarantees that the visitor will eventually find the exit. Simply choose either the right or left wall, and follow it. Of course, there's no guarantee which strategy (left or right) will be better, and the path taken is seldom the most efficient. (It also doesn't work on mazes with exits that are not on the edge; those types of mazes are not represented in this problem.)

As the proprieter of a cornfield that is about to be converted into a maze, you'd like to have a computer program that can determine the left and right-hand paths along with the shortest path so that you can figure out which layout has the best chance of confounding visitors.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of mazes. Each maze will consist of one line with a width, w, and height, h (3 <= w, h <= 40), followed by h lines of w characters each that represent the maze layout. Walls are represented by hash marks ('#'), empty space by periods ('.'), the start by an 'S' and the exit by an 'E'.

Exactly one 'S' and one 'E' will be present in the maze, and they will always be located along one of the maze edges and never in a corner. The maze will be fully enclosed by walls ('#'), with the only openings being the 'S' and 'E'. The 'S' and 'E' will also be separated by at least one wall ('#').

You may assume that the maze exit is always reachable from the start point.

Output

For each maze in the input, output on a single line the number of (not necessarily unique) squares that a person would visit (including the 'S' and 'E') for (in order) the left, right, and shortest paths, separated by a single space each. Movement from one square to another is only allowed in the horizontal or vertical direction; movement along the diagonals is not allowed.

Sample Input

2
8 8
########
#......#
#.####.#
#.####.#
#.####.#
#.####.#
#...#..#
#S#E####
9 5
#########
#.#.#.#.#
S.......E
#.#.#.#.#
#########

Sample Output

37 5 5
17 17 9
题意:给出一个迷宫,求出始终沿着左边墙走出去时间,始终沿着右边墙走走出去时间以及任意走最短时间。

思路:左右走分别dfs,任意走bfs。

代码:

#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
#define maxn 50

char s[maxn][maxn];
int h,w;
int dx[] = {-1,0,1,0};
int dy[] = {0,1,0,-1};
struct Node{
	int x,y;
	int dir;  // 0 1 2 3 :  up right down left
	int step;
	Node(){}
	Node(int a,int b,int c):x(a),y(b),step(c){}
}start,stop;

int bfs(){
	Node node;
	bool v[maxn][maxn];
	memset(v,false,sizeof v);
	queue<Node> que;
	que.push(start);
	v[start.x][start.y] = true;
	while(!que.empty()){
		node = que.front();
		que.pop();
		if(node.x==stop.x && node.y==stop.y) return node.step;
		
		for(int i=0;i<4;i++){
			int xx = node.x+dx[i], yy = node.y+dy[i];
			if(xx>=0 && xx<h && yy>=0 && yy<w && s[xx][yy]!='#' && !v[xx][yy]){
				v[xx][yy] = true;
				que.push(Node(xx,yy,node.step+1));
			}
		}
	}
	return 0;
}

int dfs_left(int x,int y,int dir,int step){
	if(x==stop.x && y==stop.y) return step;
	
	int xx,yy;
	int dir1 = (dir-1+4)%4;
	xx = x+dx[dir1], yy = y+dy[dir1];
	if(s[xx][yy]!='#') return dfs_left(xx,yy,dir1,step+1);
	
	int dir2 = dir;
	xx = x+dx[dir2], yy = y+dy[dir2];
	if(s[xx][yy]!='#') return dfs_left(xx,yy,dir2,step+1);
	
	int dir3 = (dir+1)%4;
	xx = x+dx[dir3], yy = y+dy[dir3];
	if(s[xx][yy]!='#') return dfs_left(xx,yy,dir3,step+1);
	
	int dir4 = (dir+2)%4;
	xx = x+dx[dir4], yy = y+dy[dir4];
	if(s[xx][yy]!='#') return dfs_left(xx,yy,dir4,step+1);
}

int dfs_right(int x,int y,int dir,int step){
	if(x==stop.x && y==stop.y) return step;
	
	int xx,yy;
	int dir1 = (dir+1)%4;
	xx = x+dx[dir1], yy = y+dy[dir1];
	if(s[xx][yy]!='#') return dfs_right(xx,yy,dir1,step+1);
	
	int dir2 = dir;
	xx = x+dx[dir2], yy = y+dy[dir2];
	if(s[xx][yy]!='#') return dfs_right(xx,yy,dir2,step+1);
	
	int dir3 = (dir-1+4)%4;
	xx = x+dx[dir3], yy = y+dy[dir3];
	if(s[xx][yy]!='#') return dfs_right(xx,yy,dir3,step+1);
	
	int dir4 = (dir+2)%4;
	xx = x+dx[dir4], yy = y+dy[dir4];
	if(s[xx][yy]!='#') return dfs_right(xx,yy,dir4,step+1);
}

int main(){
	int n;
	scanf("%d",&n);
	while(n--){
		scanf("%d %d\n",&w,&h);
		for(int i=0;i<h;i++){
			for(int j=0;j<w;j++){
				scanf("%c",&s[i][j]);
				if(s[i][j]=='S'){
					start.x = i;
					start.y = j;
					start.step = 1;
					//printf("##%d %d\n",i,j);
				}
				if(s[i][j]=='E'){
					stop.x = i;
					stop.y = j;
					//printf("##%d %d\n",i,j);
				}
			}
			getchar();
		}
		int x  = start.x, y = start.y;
		for(int i=0;i<4;i++){
			int xx = x+dx[i], yy = y+dy[i];
			if(xx>=0 && xx<h && yy>=0 && yy<w && s[xx][yy]!='#'){
				start.dir = i;
				break;
			}
		}
		printf("%d %d %d\n",dfs_left(x,y,start.dir,1),dfs_right(x,y,start.dir,1),bfs());
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值