unbuntu 12.04新安装qt5.4配置及问题解决。

原创 2015年07月08日 17:17:57


1、设置环境变量。执行gedit ~/.bashrc 添加如下内容:

QTDIR=/usr/local/Trolltech/Qt-4.8.6/
PATH=$QTDIR/bin:$PATH
MANPATH=$QTDIR/doc/man:$MANPATH
LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH
export QTDIR PATH MANPATH LD_LIBRARY_PATH

之后重启。

2 新安装5.4之后,打开qtcreator,

建立新工程,发现提示没有编译器,

<span style="font-size:18px;">sudo apt-get installbuild-essential </span>

配置环境g++后,仍然提示错误

原因是配置kits中


编译器没有选,这里遇到情况是,选择了也没有用,

于是,我Add了一个kits,并且选择了编译器,可以了。

3ubuntu 12.04安装qt5.4 编译程序cannot find -lGL问题


  1. sudo apt-get install libglu1-mesa-dev  


相关文章推荐

unbuntu12.04解决自动锁屏问题

  • 2016年02月15日 11:19
  • 553B
  • 下载

unbuntu server12.04配置hadoop2.7.1(四):hadoop 2.7.1的安装(所有2.x版本都可以)

1.配置hadoop之前要先安装java,这里用的java版本是java7,当然,8应该也可以,32位或者64位都可以。我是直接ppa安装的。这个方法在(一)里面说过了。要说的是java -versi...

unbuntu server12.04配置hadoop2.7.1(三):虚拟机的安装和配置。

1.我使用的环境, 本机的系统:window8, 虚拟机的系统:ubuntu-12.04.5-server-i386,(这是server,没有界面,全命令行。从功能上看,桌面版也可以实现而且有界面...

ubuntu 12.04版本的Qt5.4creator安装qwt6.1.3,亲测,可用

环境:如题,我的win10下的虚拟机有两个QTcreator版本,主要是用5.4 1、下载qwt,注意是ubuntu下安装,我下载的是后缀为tar.bz2版本 网址:https://sourcefor...

VS2013安装配置Qt5.4.1及所遇问题解决方案

VS2013安装配置Qt5.4.1及所遇问题解决方案 资源下载和安装 需要下列资源: Visual Studio 2013Qt SDK 5.4.1(qt-opensource-w...

VTK6.3结合QT5.4在VS2013上编译安装一些问题和解决

现在要使用VTK6.3安装过程中发现了一些问题,找了很久才终于解决,因此写下来相关问题与解决方法与大家分享,希望能给大家带来帮助。...
  • windfz
  • windfz
  • 2017年03月06日 15:50
  • 673

ubuntu12.04安装fcitx问题解决

Fcitx──小企鹅输入法:Free Chinese Input Toy for X是一个以GPL方式发布的、基于XIM的简体中文输入法集合(原为G五笔),包括五笔、五笔拼音、二笔、仓颉、晚风、冰蟾全...
  • ys_073
  • ys_073
  • 2013年01月03日 21:08
  • 2049

Ubuntu12.04安装中fbterm问题解决

这两天安装fbterm的时候,遇到了不少问题,不过最后通过查资料都一一化解,哈哈,很不错。 问题主要集中在安装的第一步: ./configure 这一步的错误大部分都是: ch...
  • swagle
  • swagle
  • 2013年06月09日 23:21
  • 1684

Ubuntu12.04编译Android4.0.1源码全过程-----附wubi安装ubuntu编译android源码硬盘空间不够的问题解决

本文详细记录了wubi安张ubuntu12.04(30G空间)环境下,编译android4.0.1源码的全过程,及问题解决,尤其是因硬盘空间不够导致编译报错的问题。...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:unbuntu 12.04新安装qt5.4配置及问题解决。
举报原因:
原因补充:

(最多只允许输入30个字)