PhpStorm 7.0版本图文解说,支持PHP 5.5

原创 2013年12月04日 11:47:32

PhpStorm 7.0版本终于在2013年与广大开发者见面了!鉴于PhpStorm 7.0测试版中对PHP语言最新版的支持,JetBrains没让大家失望,PhpStorm 7.0正式版本中,最大的变化就是对PHP 5.5的支持,并提供各种新功能。


对于一款智能的PHP IDE发布新版,增加新功能。我们的测试人员第一时间下载并安装了试用版,并验证了是否支持PHP 5.5。其结果是我们在使用PhpStorm时,发现,我们可以切换PHP语言版本,而不影响PHP其他水平的开发者的继续使用!
http://image.evget.com/images/article/2013/PhpStorm7-PHP-5-5-1.png

接来下,我们将陆续测试使用PHP语言进行编程,并总结其效果和功能。
PhpStorm新的高亮显示,有所变化,这个大家从截图中是一目了然,而接下来要说的是,PhpStorm引擎为执行迭代器提供了一个简单易懂的方法。在循环中,这种迭代会返回所有值并携带新“yields”关键词。如
http://image.evget.com/images/article/2013/PhpStorm7-PHP-5-5-2.png

测试运行封闭类各队列的每个元素和“yields”映射值:
http://image.evget.com/images/article/2013/PhpStorm7-PHP-5-5-3.png

在测试最终关键词时,发现其允许被清除,然后返回一个异常。这样在数据库连接时,我们可以淡定的关闭连接,而不用去在意抛出的异常。
http://image.evget.com/images/article/2013/PhpStorm7-PHP-5-5-4.png

测试人员决定测试下PHP 5.5在PhpStorm能否实现PHP语言的自身特点,便是在循序中使用列表。结果也是令人满意的:
http://image.evget.com/images/article/2013/PhpStorm7-PHP-5-5-5.png

其中,测试人员比较欣慰的是,即便是最新的PHP 5.5也是有新规则的代码智能完成的,并更加突出了高亮显示。php爱好者欢迎加群探讨:304224365 ,验证:csl,谢谢!
版权声明:本文为博主原创文章,未经博主允许不得转载。

相关文章推荐

PhpStorm 配置php7.0环境

php是我见过最恶心需要配环境的php小白一个 喜欢做死 于是选了配置phpstorm环境 网上的教程大都很老了 所以来更一波 下载xmapp7..0版本 是的你没看错,就是32位 是的你...

linux内核编程4部曲之一:linux内核编译(2.6.12版本)图文解说

原文地址:http://blog.chinaunix.net/uid-24782829-id-3211008.html linux内核编程4部曲之一:linux内核编译(2.6.12版本...

linux内核编译(3.0.1版本)图文解说

本文参考:http://blog.chinaunix.net/uid-24782829-id-3211008.html一、编译环境ubuntu 10.04.1,要编译的内核源码版本3.0.1二、下载并...

wampserver 搭建php开发环境 phpstorm 提供注册码

phpstorm wampserver 图文教程搭建php开发环境 提供注册码

(二)Centos7下Yum更新安装PHP5.5,5.6,7.0

yum源默认的版本太低了,手动安装有一些麻烦,想采用Yum更新安装的可以使用下面的方案:1.检查当前安装的PHP包yum list installed | grep php如果有安装的PHP包,先删除...

在WAMPSERVER下增加多版本的PHP(PHP5.3,PHP5.4,PHP5.5)完美支持。

WAMPServer可以让开发者在Windows系统下快速搭建WAMP环境,它支持多版本的Apache、MySQL、PHP之间的相互切换,互不影响,对于PHPer开发者来讲极为方便快速。 以下是...

在WAMPSERVER下增加多版本的PHP(PHP5.3,PHP5.4,PHP5.5)支持。

开篇提示:重中之重,如果apache启动不起来,一定要先确认自己版本正确匹配,然后在排查其他错误 WAMPServer可以让开发者在Windows系统下快速搭建WAMP环境,它支持多版本的A...

在WAMPSERVER下增加多版本的PHP(PHP5.3,PHP5.4,PHP5.5)支持。

WAMPServer可以让开发者在Windows系统下快速搭建WAMP环境,它支持多版本的Apache、MySQL、PHP之间的相互切换,互不影响,对于PHPer开发者来讲极为方便快速。 以下是...

在WAMPSERVER下增加多版本的PHP(PHP5.3,PHP5.4,PHP5.5)支持。

WAMPServer可以让开发者在Windows系统下快速搭建WAMP环境,它支持多版本的Apache、MySQL、PHP之间的相互切换,互不影响,对于PHPer开发者来讲极为方便快速。 以下是在W...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:深度学习:神经网络中的前向传播和反向传播算法推导
举报原因:
原因补充:

(最多只允许输入30个字)