USACO-cha1-sec1.1 Friday the Thirteenth

20 篇文章 0 订阅
16 篇文章 0 订阅
Friday the Thirteenth

Is Friday the 13th really an unusual event?

That is, does the 13th of the month land on a Friday less often than on any other day of the week? To answer this question, write a program that will compute the frequency that the 13th of each month lands on Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, and Saturday over a given period of N years. The time period to test will be from January 1, 1900 to December 31, 1900+N-1 for a given number of years, N. N is positive and will not exceed 400.

Note that the start year is NINETEEN HUNDRED, not 1990.

There are few facts you need to know before you can solve this problem:

  • January 1, 1900 was on a Monday.
  • Thirty days has September, April, June, and November, all the rest have 31 except for February which has 28 except in leap years when it has 29.
  • Every year evenly divisible by 4 is a leap year (1992 = 4*498 so 1992 will be a leap year, but the year 1990 is not a leap year)
  • The rule above does not hold for century years. Century years divisible by 400 are leap years, all other are not. Thus, the century years 1700, 1800, 1900 and 2100 are not leap years, but 2000 is a leap year.

Do not use any built-in date functions in your computer language.

Don't just precompute the answers, either, please.

PROGRAM NAME: friday

INPUT FORMAT

One line with the integer N.

SAMPLE INPUT (file friday.in)

20

OUTPUT FORMAT

Seven space separated integers on one line. These integers represent the number of times the 13th falls on Saturday, Sunday, Monday, Tuesday, ..., Friday.

SAMPLE OUTPUT (file friday.out)

36 33 34 33 35 35 34
————————————————————涨姿势的分割线————————————————————
思路:一开始是手工模拟了一遍,设计了计算某月某日是当年第几天的函数(其实是以前做过的啦!)如下:
#define leap(y) (y % (y%100?4:400) == 0)
int month[13] = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
int cal(int year, int mon, int day){
	int days = day, i;
	for(i = 1; i < mon; i++)
		days += month[i];
	if(mon > 2&&leap(year))	days++;
	return days;
 }
(参考AOJ-59) 之后跨年计算。其中ans[0]是星期天,注意格式顺序要求!
代码如下:
/*
ID: j.sure.1
PROG: friday
LANG: C++
*/
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
using namespace std;
#define leap(y) (y % (y%100?4:400) == 0)
int month[13] = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
int cal(int year, int mon, int day){
	int days = day, i;
	for(i = 1; i < mon; i++)
		days += month[i];
	if(mon > 2&&leap(year))	days++;
	return days;
 }
int main() {
    int n, ans[7] = {}, sum = 0, cross = 0;
    freopen("friday.in", "r", stdin);
    scanf("%d", &n);
    for(int i = 1900; i <= 1900+n-1; i++) {
		for(int j = 1; j <= 12; j++) {
			sum = cal(i, j, 13);
			ans[(sum+cross) % 7]++;
		}
		cross += leap(i) ? 366 : 365;
	}
	freopen("friday.out", "w", stdout);
	printf("%d ", ans[6]);
	for(int i = 0; i < 5; i++)
		printf("%d ", ans[i]);
	printf("%d\n", ans[5]);
    return 0;
}
手工模拟的方法还是比较推荐的,但是有一个公式叫做蔡勒公式:专门计算1582年10月15日(罗马教皇规定该年10月4日之后那天为15日)之后,某天是星期几的。
参见:百度百科
之后我就用蔡勒公式过了一遍:
/*
ID: j.sure.1
PROG: friday
LANG: C++
*/
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <stack>
using namespace std;
int main() {
	int w, y, c, n, m, d = 13;
	int year;
	freopen("friday.in", "r", stdin);
	scanf("%d", &n);
	int ans[7] = {};
	for(int year = 1900; year <= 1900+n-1; year++) {
		c = year / 100;
		y = year % 100;
		for(m = 3; m <= 12; m++) {
			w = ((y + (y>>2) + (c>>2) - (c<<1) + 26*(m+1)/10 + d - 1) % 7 + 7) % 7;
			ans[w]++;
		}
		y--;
		if(y < 0) {
			c--; y = 99;
		}
		for(m = 13; m <= 14; m++) {
			w = ((y + (y>>2) + (c>>2) - (c<<1) + 26*(m+1)/10 + d - 1) % 7 + 7) % 7;
			ans[w]++;
		}
	}
	freopen("friday.out", "w", stdout);
	printf("%d ", ans[6]);
	for(int i = 0; i < 5; i++)
		printf("%d ", ans[i]);
	printf("%d\n", ans[5]);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值