【最小费用最大流】POJ-2195 Going Home

Going Home
Time Limit: 1000MS Memory Limit: 65536K
   

Description

On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters a house. The task is complicated with the restriction that each house can accommodate only one little man. 

Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a '.' means an empty space, an 'H' represents a house on that point, and am 'm' indicates there is a little man on that point. 

You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.

Input

There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both N and M are between 2 and 100, inclusive. There will be the same number of 'H's and 'm's on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M.

Output

For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay.

Sample Input

2 2
.m
H.
5 5
HH..m
.....
.....
.....
mm..H
7 8
...H....
...H....
...H....
mmmHmmmm
...H....
...H....
...H....
0 0

Sample Output

2
10
28
————————————————————とても水の分割線————————————————————
思路:建立二分图,费用为曼哈顿距离。裸题。
代码如下:
/*
ID: j.sure.1
PROG:
LANG: C++
*/
/****************************************/
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <string>
#include <climits>
#include <iostream>
#define LL long long
using namespace std;
const int INF = 0x3f3f3f3f;
/****************************************/
const int N = 1e4, M = 1e5;
struct Node {
	int u, v, w, c;
	int next;
	Node(){}
	Node(int _u, int _v, int _w, int _c, int _next):
		u(_u), v(_v), w(_w), c(_c), next(_next){}
}edge[M];
int tot, S, T, head[N], pre[N], path[N], dis[N], q[N];
bool inq[N];
int n, m;
char mat[111][111];

void init()
{
	tot = 0;
	memset(head, -1, sizeof(head));
}

void add(int u, int v, int w, int c)
{
	edge[tot] = Node(u, v, w, c, head[u]); head[u] = tot++;
	edge[tot] = Node(v, u, 0, -c, head[v]); head[v] = tot++;
}

bool spfa()
{
	memset(inq, 0, sizeof(inq));
	memset(dis, 0x3f, sizeof(dis));
	dis[S] = 0; inq[S] = 1;
	int fron = 0, rear = 0;
	q[rear++] = S;
	while(fron < rear) {
		int u = q[fron%N]; fron++;
		inq[u] = 0;
		for(int i = head[u]; ~i; i = edge[i].next) {
			int v = edge[i].v;
			if(edge[i].w > 0 && dis[v] > dis[u] + edge[i].c) {
				dis[v] = dis[u] + edge[i].c;
				pre[v] = u; path[v] = i;
				if(!inq[v]) {
					inq[v] = 1;
					q[rear%N] = v; rear++;
				}
			}
		}
	}
	return dis[T] < INF;
}

int EK()
{
	int ret = 0;
	while(spfa()) {
		int mini = INF;
		for(int i = T; i != S; i = pre[i]) {
			mini = min(mini, edge[path[i]].w);
		}
		for(int i = T; i != S; i = pre[i]) {
			edge[path[i]].w -= mini;
			edge[path[i]^1].w += mini;
		}
		ret += mini * dis[T];
	}
	return ret;
}

int main()
{
#ifdef J_Sure
//	freopen("000.in", "r", stdin);
//	freopen(".out", "w", stdout);
#endif
	int house[111][2], man[111][2];
	while(scanf("%d%d", &n, &m), n||m) {
		init();
		int cnt1 = 0, cnt2 = 0;
		for(int i = 1; i <= n; i++) {
			for(int j = 1; j <= m; j++) {
				scanf(" %c", &mat[i][j]);
				if(mat[i][j] == 'H') {
					house[cnt1][0] = i;
					house[cnt1++][1] = j;
				}
				else if(mat[i][j] == 'm') {
					man[cnt2][0] = i;
					man[cnt2++][1] = j;
				}
			}
		}
		S = cnt1 + cnt2; T = S + 1;
		for(int i = 0; i < cnt2; i++) {
			add(S, i, 1, 0);
			for(int j = 0; j < cnt1; j++) {
				int &x1 = man[j][0], &y1 = man[j][1];
				int &x2 = house[i][0], &y2 = house[i][1];
				int cost = abs(x1-x2) + abs(y1-y2);
				add(i, j+cnt2, INF, cost);
			}
		}
		for(int j = 0; j < cnt1; j++) {
			add(j+cnt2, T, 1, 0);
		}
		int ans = EK();
		printf("%d\n", ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值