【BFS|位运算】POJ-1753 Flip Game

22 篇文章 0 订阅
7 篇文章 0 订阅
Flip Game
Time Limit: 1000MS Memory Limit: 65536K
   

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4
————————————————————歯が痛んで分割線————————————————————
前言:啊…………给学弟出的训练题我做了这么久…………
思路:4*4的图,只有两种颜色。果断状态压缩。。
记录的元素——
1. 一个int(16位正好代表16个格子)
2. 步数
3. 父节点
枚举16个格子,每次从队列中取出一个结点之后,从父结点向后枚举
P.S. 本来是一道水题,大于小于号写反了,调了这么久,唉。以后模块式的代码一定要查错!
代码如下:
/*
ID: j.sure.1
PROG:
LANG: C++
*/
/****************************************/
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <set>
#include <string>
#include <climits>
#include <iostream>
#define LL long long
using namespace std;
const int INF = 0x3f3f3f3f;
/****************************************/
struct Node {
	int m, step, last;
	Node(){}
	Node(int _m, int _step, int _last):
		m(_m), step(_step), last(_last){}
};
queue <Node> q;
bool vis[0xFFFF+1];

Node pull(Node t, int i)
{
	Node u;
	t.m ^= 1 << i;
	int x = i >> 2, y = i & 3;//取出行和列
	if(x > 0) t.m ^= 1 << (i-4);
	if(x < 3) t.m ^= 1 << (i+4);
	if(y > 0) t.m ^= 1 << (i-1);
	if(y < 3) t.m ^= 1 << (i+1);
	u.m = t.m;
	u.last = i;
	u.step = t.step + 1; 
	return u;
}

int bfs()
{
	while(!q.empty()) {
		Node t = q.front();//取出队首
		q.pop();
		if(!t.m || t.m == 0xFFFF) return t.step;
		if(t.step >= 16) return -1;//剪枝
		for(int i = t.last + 1; i < 16; i++) {
			Node u = pull(t, i);
			if(!vis[u.m]) {
				vis[u.m] = 1;
				q.push(u);
			}//进队
		}
	}
	return -1;
}

int main()
{
#ifdef J_Sure
	freopen("000.in", "r", stdin);
	freopen("999.out", "w", stdout);
#endif
	char s[10];
	int x = 0;
	for(int i = 0; i < 4; i++) {
		scanf("%s", s);
		for(int j = 0; j < 4; j++) {
			if(s[j] == 'b') {
				x = x << 1 | 1;
			}
			else x <<= 1;
		}
	}
	vis[x] = 1;
	q.push(Node(x, 0, -1));
	int ans = bfs();
	if(ans == -1) puts("Impossible");
	else printf("%d\n", ans);
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值