【DP|数学+预处理】POJ-1160 Post Office

69 篇文章 0 订阅

Post Office
Time Limit: 1000MS Memory Limit: 10000K

Description
There is a straight highway with villages alongside the highway. The highway is represented as an integer axis, and the position of each village is identified with a single integer coordinate. There are no two villages in the same position. The distance between two positions is the absolute value of the difference of their integer coordinates.

Post offices will be built in some, but not necessarily all of the villages. A village and the post office in it have the same position. For building the post offices, their positions should be chosen so that the total sum of all distances between each village and its nearest post office is minimum.

You are to write a program which, given the positions of the villages and the number of post offices, computes the least possible sum of all distances between each village and its nearest post office.

Input
Your program is to read from standard input. The first line contains two integers: the first is the number of villages V, 1 <= V <= 300, and the second is the number of post offices P, 1 <= P <= 30, P <= V. The second line contains V integers in increasing order. These V integers are the positions of the villages. For each position X it holds that 1 <= X <= 10000.

Output
The first line contains one integer S, which is the sum of all distances between each village and its nearest post office.

Sample Input

10 5
1 2 3 6 7 9 11 22 44 50

Sample Output

9

Source
IOI 2000


题意: 给出n个城市的绝对位置,在某些城市上建立m个邮局,使得所有城市和离它最近的邮局的距离之和最小。
思路: 以前做过这种DP,数学知识:中位数距离其他所有数字的距离之和最短。
证明可以看看这儿:HDU-1227
思路和代码几乎一模一样。
代码如下:

/*
 * ID: j.sure.1
 * PROG:
 * LANG: C++
 */
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <set>
#include <string>
#include <iostream>
#define PB push_back
#define LL long long
using namespace std;
const int INF = 0x3f3f3f3f;
const double eps = 1e-8;
/****************************************/
const int N = 305, M = 35;
int n, m;
int w[N];
int dp[M][N], cost[N][N];

void pre_treat()
{
    for(int i = 1; i <= n; i++) {
        for(int j = 1; j <= n; j++) {
            cost[i][j] = 0;
            int mid = (i+j)>>1;
            for(int k = i; k <= j;k++) {
                cost[i][j] += abs(w[mid] - w[k]);
            }
        }
    }
}

int solve()
{
    for(int j = 1; j <= n; j++) {
        dp[1][j] = cost[1][j];
    }
    for(int i = 2; i <= m; i++) {
        for(int j = 1; j <= n; j++) {
            int ret = INF;
            for(int k = 1; k < j; k++) {
                ret = min(ret, dp[i-1][k] + cost[k+1][j]);
            }
            dp[i][j] = ret;
        }
    }
    return dp[m][n];
}

int main()
{
#ifdef J_Sure
    freopen("000.in", "r", stdin);
    //freopen("999.out", "w", stdout);
#endif
    scanf("%d%d", &n, &m);
    for(int i = 1; i <= n; i++) {
        scanf("%d", &w[i]);
    }
    pre_treat();
    int ans = solve();
    printf("%d\n", ans);
    return 0;
}
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值