【DP】POJ-1745 Divisibility

69 篇文章 0 订阅

Divisibility
Time Limit: 1000MS Memory Limit: 10000K

Description
Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions: 17 + 5 + -21 + 15 = 16
17 + 5 + -21 - 15 = -14
17 + 5 - -21 + 15 = 58
17 + 5 - -21 - 15 = 28
17 - 5 + -21 + 15 = 6
17 - 5 + -21 - 15 = -24
17 - 5 - -21 + 15 = 48
17 - 5 - -21 - 15 = 18
We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible by 5.

You are to write a program that will determine divisibility of sequence of integers.

Input
The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space.
The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it’s absolute value.

Output
Write to the output file the word “Divisible” if given sequence of integers is divisible by K or “Not divisible” if it’s not.

Sample Input

4 7
17 5 -21 15

Sample Output

Divisible

Source
Northeastern Europe 1999


题意: 给出n个有正有负的数字,在它们中间添加加号或者减号,问能否得到一个表达式的值除得尽K。
思路: 暴力DP,dp[i][j]表示dp到第i个数字的时候余数j是否可达,可达则为true,不可达则为false。
初始化的时候dp[0][0] = true.
代码如下:

/*
 * ID: j.sure.1
 * PROG:
 * LANG: C++
 */
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <set>
#include <string>
#include <iostream>
#define PB push_back
#define LL long long
using namespace std;
const int INF = 0x3f3f3f3f;
const double eps = 1e-8;
/****************************************/
const int N = 1e4 + 5, K = 105;
int n, k;
int a[N];
bool dp[N][K];

bool solve()
{
    memset(dp, 0, sizeof(dp));
    dp[0][0] = true;
    for(int i = 1; i <= n; i++) {
        for(int j = 0; j < k; j++) if(dp[i-1][j]) {
            int t1 = ((j + a[i]) % k + k) % k;
            int t2 = ((j - a[i]) % k + k) % k;
            dp[i][t1] = true;
            dp[i][t2] = true;
        }
    }
    return dp[n][0];
}

int main()
{
#ifdef J_Sure
    freopen("000.in", "r", stdin);
    //freopen("999.out", "w", stdout);
#endif
    scanf("%d%d", &n, &k);
    for(int i = 1; i <= n; i++) {
       scanf("%d", &a[i]);
    }
    bool ok = solve();
    if(ok) puts("Divisible");
    else puts("Not divisible");
    return 0;
}
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值