poj 2356 Find a multiple 抽屉原理

Find a multiple
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6263 Accepted: 2734 Special Judge

Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order.

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

5
1
2
3
4
1

Sample Output

2
2
3

有x 个盒子,有x + 1 个物品随便放入这些盒子,那么必然至少有一个盒子里面有 >= 2 个物品;
N 个数,sum[i] = sum(a1 + ...+ ai) ,sum 共有 N个,如果存在 sum[i] % N = 0; 那么答案就知道的; 任何数%N 只有0,1,2 ... N-1, N种情况; 省区为 0的情况,
那么就有N - 1 个盒子; 把 N 个 sumi 放入,必然存在至少俩个sumi, sumj (j < i)在同一个盒子,即 sumi % N == sumj % N; so (sumi - sumj ) % N == 0;

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<string>
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<list>
#include<map>
#include<set>
using namespace std;

int res[10010];
int a[10010];
int sum[10010];
int n;
void work(){
    memset(res, 0, sizeof(res));
    sum[0] = 0;
    for(int i = 1; i <= n; i++){
        sum[i] = sum[i - 1] + a[i];
        int tp = sum[i] % n;
        if(tp == 0){
            printf("%d\n", i);
            for(int j = 1; j <= i; j++)
                printf("%d\n", a[j]);
            return ;
        }
        if(res[tp] == 0){
            res[tp] = i;
        }else{
            printf("%d\n", i - res[tp]);
            for(int j = res[tp] + 1; j <= i; j++)
                printf("%d\n", a[j]);
            return ;
        }

    }
}
int main()
{

//	freopen("in.txt","r",stdin);
    while(~scanf("%d", &n)){
        for(int i = 1; i <= n; i++)
            scanf("%d", &a[i]);
        work();
    }

	return 0;
}

//http://poj.org/problem?id=2356




 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值