HDU 1250 Hat's Fibonacci 大数加法 进位10000000

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6880    Accepted Submission(s): 2270

Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number
Input
Each line will contain an integers. Process to end of file.
Output
For each case, output the result in a line.
Sample Input
  
  
100
Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

/*
1250 Hat's Fibonacci
大数运算 少于2005位 

以下的方法 内存超过了 
int a[7036][2050]={0},b[7036];
int main(){
    int i,j,n,k,z; 

        a[1][0]=1;
        a[2][0]=1;
        a[3][0]=1;
        a[4][0]=1;
        b[1]=1;
        b[2]=1;
        b[3]=1;
        b[4]=1;        
        k=1;//长度 
        for(i=5;i<7036;i++)
        {
            for(j=0;j<k;j++)
                a[i][j]=a[i-1][j]+a[i-2][j]+a[i-3][j]+a[i-4][j];
            z=0;//进位 
            for(j=0;j<k;j++)
            {
                a[i][j]+=z;
                z=a[i][j]/10;
                a[i][j]%=10;
            } 
            while(z)//仍有进位 
            {
                a[i][k++]=z%10;
                z/=10;
            }
            b[i]=k;
        }
    
    重新构思方法 每个里面放8位 本来是10进位 改为10^8    
*/
#include<iostream>
#include<cmath>
using namespace std;
int a[7036][251]={0},b[7036];

int main(){
    int i,j,n,k,z; 

        a[1][0]=1;
        a[2][0]=1;
        a[3][0]=1;
        a[4][0]=1;
        b[1]=1;
        b[2]=1;
        b[3]=1;
        b[4]=1;        
        k=1;//长度 
        for(i=5;i<7036;i++)
        {
            for(j=0;j<k;j++)
                a[i][j]=a[i-1][j]+a[i-2][j]+a[i-3][j]+a[i-4][j];
            z=0;//进位 
            for(j=0;j<k;j++)
            {
                a[i][j]+=z;
                z=a[i][j]/100000000;
                a[i][j]%=100000000;
            } 
            while(z)//仍有进位 
            {
                a[i][k++]=z%100000000;
                z/=100000000;
            }
            b[i]=k;
        }
        
        while(scanf("%d",&n)!=EOF)
        {
            printf("%d",a[n][b[n]-1]);//第一位不输出前面的0 
            for(j=b[n]-2;j>=0;j--)
                printf("%08d",a[n][j]);
            printf("\n");
        } 
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据提供的引用内容,HDU1622是一道关于二叉树的题目,要求读入一系列二叉树的节点信息,输出它们的层序遍历结果。如果输入的二叉树不完整或存在重复节点,则输出"not complete"。下面是Java的实现代码: ```java import java.util.LinkedList; import java.util.Queue; import java.util.Scanner; public class Main { static class Node { int val; Node left, right; public Node(int val) { this.val = val; } } public static void main(String[] args) { Scanner sc = new Scanner(System.in); while (sc.hasNext()) { String s = sc.nextLine(); if (s.isEmpty()) { continue; } String[] nodes = s.split("\\s+"); Node root = new Node(Integer.parseInt(nodes[0].substring(1))); Queue<Node> queue = new LinkedList<>(); queue.offer(root); boolean isComplete = true; for (int i = 1; i < nodes.length - 1; i += 2) { Node cur = queue.poll(); if (!nodes[i].equals("()")) { cur.left = new Node(Integer.parseInt(nodes[i].substring(1))); queue.offer(cur.left); } else { isComplete = false; } if (!nodes[i + 1].equals("()")) { cur.right = new Node(Integer.parseInt(nodes[i + 1].substring(0, nodes[i + 1].length() - 1))); queue.offer(cur.right); } else { isComplete = false; } } if (!isComplete) { System.out.println("not complete"); continue; } StringBuilder sb = new StringBuilder(); queue.offer(root); while (!queue.isEmpty()) { Node cur = queue.poll(); sb.append(cur.val).append(" "); if (cur.left != null) { queue.offer(cur.left); } if (cur.right != null) { queue.offer(cur.right); } } System.out.println(sb.toString().trim()); } } } ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值