HDU 1398 Square Coins 母函数

Square Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8404    Accepted Submission(s): 5721


Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.
 

Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
 

Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.
 

Sample Input
  
  
2 10 30 0
 

Sample Output
  
  
1 4 27
/*
HDOJ 1398 母函数 
1,4,9,16...289 

砝码:(1+x)(1+x^2)(1+x^3)(1+x^4)=1+x+x^2+2x^3+2x^4+2x^5+2x^6+2x^7+x^8+x^9+x^10 ,系数即为方案数。
x表示砝码,x的指数表示重量
都是一个的情况,例称出重量为6的物品:①、1,2,3;②、2,4两种方案。

所以这里:
G(x)=(1+x+x^2+…)(1+x^4+x^8+…)…(1+x^289+x^578+…),然后每次查询相当于查询x^n的系数是多少。
*/ 

#include<iostream>
#include<stdio.h>
using namespace std;
// c1是保存各项质量砝码可以组合的数目
// c2是中间量,保存没一次的情况

int c1[10002],c2[10002];
int main()
{
	int i,j,k,sum;
	while(scanf("%d",&sum),sum)
	{
		for(i=0;i<=sum;i++)// 首先对c1初始化,由第一个表达式(1+x+x2+..xn)初始化
		{
			c1[i]=1;
			c2[i]=0;
		}
		
		for(i=2;i*i<=sum;i++)//钱的种类数目 最大就是sum/(i*i) 
		{
			for(j=0;j<=sum;j++)//第j个变量 
			{
					//k表示的是第j个指数,所以k每次增i(因为第i个表达式的增量是i)
					for(k=0;k+j<=sum;k+=i*i)
						c2[k+j]+=c1[j];
				
			}
			for(j=0;j<=sum;j++)  
            {  
                c1[j]=c2[j];  
                c2[j]=0;  
            }
		}
		printf("%d\n",c1[sum]);	
	}
	return 0;
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值