HDU 1496 Equations hash

Equations

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5596    Accepted Submission(s): 2221

Problem Description
Consider equations having the following form:
a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.
It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.
Determine how many solutions satisfy the given equation.
 
Input
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.
 
Output
For each test case, output a single line containing the number of the solutions.
 
Sample Input
  
  
1 2 3 -4 1 1 1 1

Sample Output
  
  
39088 0
/*
HDU 1496 hash
a*x1^2+b*x2^2 = -(c*x3^2+d*x4^2),由于会有负下标,hash存储右边的值,注意偏移 
因为x1,x2,x3,x4可以为正数或者为负数两种情况,需要把结果乘以2的4次幂。

max=100^2*50*2=1e6 
*/
#include<iostream>
#include<stdio.h>
using namespace std;
#define N 1000001
int hash[2*N];
int main()
{
	int a,b,c,d,ans,i,j;
	while(scanf("%d%d%d%d",&a,&b,&c,&d)!=EOF)
	{
		if((a>0&&b>0&c>0&d>0)||(a<0&&b<0&c<0&d<0))
		{
			printf("0\n");
			continue;
		}	
		memset(hash,0,sizeof(hash));
		for(i=1;i<=100;i++)
			for(j=1;j<=100;j++)
				hash[int(a*i*i+b*j*j+N)]++;
		ans=0;
		for(i=1;i<=100;i++)
			for(j=1;j<=100;j++)
				if(hash[int(-(c*i*i+d*j*j)+N)])
					ans+=hash[int(-(c*i*i+d*j*j)+N)];	
		printf("%d\n",ans*16);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值