Pat(Advanced Level)Practice--1033(To Fill or Not to Fill)

Pat1033代码

题目描述:

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: Cmax (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg (<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station and Hangzhou, for i=1,...N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print "The maximum travel distance = X" where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:
50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300
Sample Output 1:
749.17
Sample Input 2:
50 1300 12 2
7.10 0
7.00 600
Sample Output 2:
The maximum travel distance = 1200.00

比较复杂的贪心算法:关键是贪心策略的选择
我们用maxdis表示加一次油所能行驶的最远距离,那么从目前到maxdis的范围内搜索,会有以下几种选择的策略
1,在maxdis范围内找到价格最低的加油站,则应加的油使它能跑到该加油站
2,在1的基础上,如果在价格最低的加油站之前,存在第一个比当前加油站价格更低的加油站,则应该加油使之跑到
价格较低的加油站,然后再加油使之跑到价格最低的加油站
3,在价格最低的加油站加满油,重复1,2就可以了
AC代码:
#include<cstdio>
#include<vector>
#include<algorithm>

using namespace std;

typedef struct Gas
{
	float price;
	float distance;
}Gas;

bool cmp(const Gas &l,const Gas &r)
{
	if(l.distance<r.distance)
		return true;
	else
		return false;
}

int main(int argc,char *argv[])
{
	float c,d,a;
	int n,i,j;
	float fee;
	vector<Gas> v;
	Gas temp;
	float maxdis;
	scanf("%f%f%f%d",&c,&d,&a,&n);
	for(i=0;i<n;i++)
	{
		scanf("%f%f",&temp.price,&temp.distance);
		v.push_back(temp);
	}
	temp.price=0;
	temp.distance=d;
	v.push_back(temp);
	sort(v.begin(),v.end(),cmp);
	if(v[0].distance!=0)
	{
		printf("The maximum travel distance = 0.00\n");
		return 0;
	}
	float left;
	maxdis=c*a;
	i=0;
	fee=0;
	while(v[i].distance<d)
	{
		float minprice=-1;
		int mindex=-1,findex=-1;
		for(j=i+1;j<=n&&(v[j].distance-v[i].distance)<=maxdis;j++)
		{
			if(minprice==-1||v[j].price<minprice)
			{	   //在maxdis范围内搜索price最小的加油站                    
				minprice=v[j].price;
				mindex=j;
			}
			if(findex==-1&&v[j].price<v[i].price)//在maxdis范围内搜索第1个
				findex=j;       //price小于目前价格的加油站
		}
		if(mindex==-1)//下一个加油站距离目前加油站的距离大于所能行驶的最大
			break;   //距离maxdis
		if(findex==-1)//在maxdis范围内不存在小于目前价格的加油站
		{           //即最小价格的加油站也大于目前价格,此时应把油加满
			if(d-v[i].distance<=maxdis)//在maxdis距离内能到达终点
			{
				fee+=((d-v[i].distance)/a-left)*v[i].price;
				left=0;
				i=n;
			}
			else//不能到达终点,则加油使之能跑到maxdis范围内价格最小的加油站
			{
				fee+=(c-left)*v[i].price;
				left=c-(v[mindex].distance-v[i].distance)/a;
				i=mindex;
			}
		}
		else//maxdis范围内存在加油站价格小于当前价格,则应在本加油站加油使之
		{              //能跑到该加油站
			fee+=((v[findex].distance-v[i].distance)/a-left)*v[i].price;
			left=0;
			i=findex;
		}
	}
	if(v[i].distance==d)
		printf("%.2f\n",fee);
	else
		printf("The maximum travel distance = %.2f\n",v[i].distance+maxdis);
	
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值