HDU3367 Pseudoforest 【并查集】+【贪心】

Pseudoforest

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1729    Accepted Submission(s): 661


Problem Description
In graph theory, a pseudoforest is an undirected graph in which every connected component has at most one cycle. The maximal pseudoforests of G are the pseudoforest subgraphs of G that are not contained within any larger pseudoforest of G. A pesudoforest is larger than another if and only if the total value of the edges is greater than another one’s.

 

Input
The input consists of multiple test cases. The first line of each test case contains two integers, n(0 < n <= 10000), m(0 <= m <= 100000), which are the number of the vertexes and the number of the edges. The next m lines, each line consists of three integers, u, v, c, which means there is an edge with value c (0 < c <= 10000) between u and v. You can assume that there are no loop and no multiple edges.
The last test case is followed by a line containing two zeros, which means the end of the input.
 

Output
Output the sum of the value of the edges of the maximum pesudoforest.
 

Sample Input
  
  
3 3 0 1 1 1 2 1 2 0 1 4 5 0 1 1 1 2 1 2 3 1 3 0 1 0 2 2 0 0
 

Sample Output
  
  
3 5
 

Source

题意:这题的题意折腾了好久才懂,开始以为是求最多有一个环的最大联通分量,然后WA了,后来才知道是求多个分量的最大和,每个分量最多有一个环。

题解:边权从大到小排序,对于每条边的起点终点a、b有三种情况:

1、a、b分属两个环,此时a、b不能连接;

2、a、b其中一个属于环,此时将另一个连过去或者两个都不在环中,此时任意连;

3、a、b在同一集合,但该集合无环,此时连接a、b并生成环。

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define maxn 10002
#define maxm 100002
using std::sort;

struct Node{
	int u, v, cost;
} E[maxm];
int pre[maxn];
bool Ring[maxn];

bool cmp(Node a, Node b){
	return a.cost > b.cost;
}

int ufind(int k)
{
	int a = k, b;
	while(pre[k] != -1) k = pre[k];
	while(a != k){
		b = pre[a];
		pre[a] = k;
		a = b;
	}
	return k;
}

int greedy(int n, int m)
{
	int ans = 0, i, u, v;
	for(i = 0; i < m; ++i){
		u = E[i].u; v = E[i].v;
		u = ufind(u); v = ufind(v);
		if(Ring[u] && Ring[v]) continue;
		if(u != v){
			if(Ring[v]) pre[u] = v;
			else pre[v] = u;
			ans += E[i].cost;
		}else if(Ring[v] == false){
			Ring[v] = true;
			ans += E[i].cost;
		}
	}
	return ans;
}

int main()
{
	int n, m, a, b, c, i;
	while(scanf("%d%d", &n, &m), n||m){
		memset(pre, -1, sizeof(pre));
		memset(Ring, 0, sizeof(Ring));
		for(i = 0; i < m; ++i)
			scanf("%d%d%d", &E[i].u, &E[i].v, &E[i].cost);
		sort(E, E + m, cmp);
		printf("%d\n", greedy(n, m));
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值