[折半枚举] poj 2785 4 Values whose Sum is 0

Values whose Sum is 0
Time Limit: 15000MS Memory Limit: 228000K
Total Submissions: 17715 Accepted: 5209
Case Time Limit: 5000MS
Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .
Output

For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
Sample Output

5
Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

给定各有n个整数的四个数列A,B,C,D,要从每个数列中各取1个数,使四个数的和为0。求出这样的组合的个数。当一个数列中有多个相同的数字时,把它们作为不同的数字看待。

从4个数列中选择的话,总共有n^4种情况,所以全部判断一遍不可行。不过把他们对半分成AB和CD来考虑,就可以快速解决了。从两个数列中选择的话,只有n²种组合,所以可以进行枚举。先从A,B中取出a,b后,为了使总和为0,需要从C、D中取出c+d=-(a+b),因此先将C、D中取数字的n²种方法全部枚举出来,将这些和排好序,这样就可以运用二分搜索了。复杂度是O(n²logn)。

有时候问题的规模很大,无法枚举所有元素的组合,但能够枚举一般元素的组合。此时,将问题拆成两半以后分别枚举,再合并它们的结果,这一方法往往特别有效。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <map>
#include <cstring>
#include <set>
using namespace std;
const int MAXN = 5000;

int n,a[MAXN];
int A[MAXN],B[MAXN],C[MAXN],D[MAXN];
int CD[MAXN * MAXN];
void checkinput()
{
    for(int i = 0;i<n;i++)
        printf("%d  ",A[i]);
    printf("\n");
    for(int i = 0;i<n;i++)
        printf("%d  ",B[i]);
    printf("\n");

    for(int i = 0;i<n;i++)
        printf("%d  ",C[i]);
    printf("\n");

    for(int i = 0;i<n;i++)
        printf("%d  ",D[i]);
    printf("\n");
}

int main()
{
    scanf("%d",&n);
    for(int i = 0;i<n;i++)
        scanf("%d%d%d%d",&A[i],&B[i],&C[i],&D[i]);

    for(int i = 0;i<n;i++)
    {
        for(int j = 0; j < n;j++)
        {
            CD[i*n+j] = C[i] + D[j];
        }
    }
    sort(CD,CD+n*n);

    long long res = 0;
    for(int i = 0; i < n; i++)
    {
        for(int j = 0; j < n; j++)
        {
            int cd = -(A[i]+B[j]); //在CD中刚好为-(A[i]+B[i])的值
            res += upper_bound(CD,CD+n*n,cd) - lower_bound(CD,CD+n*n,cd);
        }
    }
    printf("%I64d\n",res);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值