hdu 1060 Leftmost Digit(数学题)

转载请注明出处:http://blog.csdn.net/u012860063

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1060



题意:

计算N^N最左边的数!

思路:

/* 数学题 
任何一个数字都可以n表示成10^(a+b)。其中a>=1,b<1。
例如


n=87455时,a=4,b=0.941784644. 


 有规律.10^a=10000.10^b=8.7455.


所以n的左边数起第一位数字。就是10^b的第一位有效数字,第二数字,是10^b的第二位有效数字。。。。
以次类推;
由sum=N^N,两边对10取对数,log10(sum)=Nlog10(N),有sum=10^(Nlog10(N));
 由于10的整数次幂首位均为1,则仅需考虑Nlog10(N)的结果的小数部分即可*/


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
  
  
2 3 4
 

Sample Output
  
  
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
代码如下:

#include <cstdio>
#include <cmath>
int main()
{
    int t;
    __int64 N,sum2;
    scanf("%d",&t);
	while(t--)
	{
		scanf("%I64d",&N);
		double sum1=N*log10(double(N));
		sum2=(__int64)sum1;
		sum1-=sum2;
		N=(__int64)pow(10.0,sum1);
		printf("%I64d\n",N);
	}
	return 0; 
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值