poj 2387 Til the Cows Come Home spfa+dis解答

转载请注明出处:http://blog.csdn.net/u012860063

题目链接:http://poj.org/problem?id=2387

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.
题意:求1到n的最短距离;

SPFA确实比dis快;

附上SPFA截图:

SPFA代码:

#include <cstdio>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <climits>
#include <malloc.h>
#include <ctype.h>
#include <queue>
#include <stack>
#include <vector>
#include <deque>
#include <set>
#include <map>
#include <iostream>
#include <algorithm>
using namespace std;
#define pi acos(-1.0)
#define INF 0xffffff
#define N 1005
#define M 2005
int n,m,k,Edgehead[N],dis[N];
struct
{
	int v,w,next;
}Edge[2*M];
bool vis[N];
void Addedge(int u,int v,int w)
{
	Edge[k].next = Edgehead[u];
	Edge[k].w = w;
	Edge[k].v = v;
	Edgehead[u] = k++;
}
int SPFA( int start)
{
	queue<int>Q;
	for(int i = 1 ; i <= n ; i++ )
		dis[i] = INF;
	dis[start] = 0;
	memset(vis,false,sizeof(vis));
	Q.push(start);
	while(!Q.empty())//直到队列为空
	{
		int u = Q.front();
		Q.pop();
		vis[u] = false;
		for(int i = Edgehead[u] ; i!=-1 ; i = Edge[i].next)//注意
		{
			int v = Edge[i].v;
			int w = Edge[i].w;
			if(dis[v] > dis[u] + w)
			{
				dis[v] = dis[u]+w;
				if( !vis[v] )//防止出现环,也就是进队列重复了  
				{
					Q.push(v);
					vis[v] = true;
				}
			}
		}
	}
	return dis[n];
}
int main()
{
	int u,v,w;
	while(~scanf("%d%d",&m,&n))
	{
		k = 1;
		memset(Edgehead,-1,sizeof(Edgehead));
		for(int i = 1 ; i <= m ; i++ )
		{
			scanf("%d%d%d",&u,&v,&w);
			Addedge(u,v,w);//双向链表
			Addedge(v,u,w);//双向链表
		}
		int s = SPFA(1);//从点1开始寻找最短路
		printf("%d\n",s);
	}
	return 0;
}

附上dis截图

Dis代码:

#include<cstdio>
#include<cstring>
#define M 20001
#define INF 0xffffff
int map[2000][2000];
int main()
{
	int i,j,k,n,m,t,a,b,c;
	int mark[M],dis[M];
	while(scanf("%d%d",&t,&n)!=EOF)
	{
		memset(mark,0,sizeof(mark));
		for(i = 1 ; i <= n ; i++ )
		{
			for(j = 1 ; j <= n ; j++ )
			{
				map[i][j]=INF;
			}
		}
		for(i = 1 ; i <= n ; i++ )
			dis[i]=INF;
		for( i = 1 ; i <= t ; i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			if(c < map[a][b])
				map[a][b]=c;
			map[b][a]=c;
		}
		dis[1]=0;
		for(i = 1; i <= n ; i++ )
		{
			int min = INF;
			for( j = 1 ; j <= n ; j++ )
			{
				if(mark[j] == 0 && dis[j] < min )
				{
					min = dis[j];
					k = j ;
				}
			}
			mark[k]=1;
			for( j = 1 ; j <= n ; j++ )
			{
				if( mark[j]==0 && dis[j]>dis[k]+map[k][j] )
				{
					dis[j]=dis[k]+map[k][j];
				}
			}
		}
		printf("%d\n",dis[n]);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值