hdu1114 Piggy-Bank 完全背包

转载请注明出处:http://blog.csdn.net/u012860063

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1114


Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!
 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.
 

Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".
 

Sample Input
  
  
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4

Sample Output
  
  
The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.
 
Source


Recommend
Eddy   |   We have carefully selected several similar problems for you:   1203  1059  1074  1024  2602 

题意:
分别知道空猪钱罐和满状态是的重量,和各种硬币的面额和重量;是确定在满状态时最坏的情况下能有多少钱,也就是至少能有多少钱;
显然是一道完全背包的题目,同一种硬币可以无限多。

代码如下:
#include <cstdio>
#define INF 0x3fffffff
#define N 10047
int f[N],p[N],w[N];
int min(int a,int b)
{
	if(a < b)
		return a;
	return b;
}
int main()
{
	int t,i,j,k,E,F,m,n;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&E,&F);
		int c = F-E;
		for(i = 0 ; i <= c ; i++)
			f[i]=INF;
		scanf("%d",&n);
		for(i = 0 ; i < n ; i++)
		{
			scanf("%d%d",&p[i],&w[i]);
		}
		f[0]=0;//因为此处假设的是小猪储钱罐 恰好装满 的情况
				//注意初始化(要求恰好装满背包,那么在初始化时除了f[0]为0其它f[1..V]均设为-∞,
				//这样就可以保证最终得到的f[N]是一种恰好装满背包的最优解。
				//如果并没有要求必须把背包装满,而是只希望价格尽量大,初始化时应该将f[0..V]全部设为0)
		for(i =0 ; i < n ; i++)
		{
			for(j = w[i] ; j <= c ; j++)
			{
				f[j] = min(f[j],f[j-w[i]]+p[i]);//此处求的是最坏的情况所以用min,确定最少的钱,当然最后就用max了,HEHE
			}
		}
		if(f[c] == INF)
			printf("This is impossible.\n");
		else
			printf("The minimum amount of money in the piggy-bank is %d.\n",f[c]);
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值