poj 1012 & hdu 1443 Joseph(约瑟夫环变形)

题目链接:

POJ  1012: http://poj.org/problem?id=1012

HDU 1443: http://acm.hdu.edu.cn/showproblem.php?pid=1443

约瑟夫环(百度百科): http://baike.baidu.com/view/717633.htm?fr=aladdin


Description

The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved. 

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy. 

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output

The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input

3
4
0

Sample Output

5
30

Source


题意:

       共有 k 个坏人 k 个好人坐成一圈(总人数就为2*k),前面的 k 个为好人(编号1~k),后面的 k 个为坏人(编号k+1~2k),

现有一个报数为 m ,从编号为 1 的人开始报数,报到 m 的人会自动的死去。

求当 m 为何值时,可以使在出现有好人死亡前,k 个坏人已经全部死掉?


注意: 当前一轮第 m 个人死后,下一轮的编号为1的人是前一轮编号为 m+1 的人,

前一轮恰好是最后一个人死掉,则下一轮循环回到开头那个人报“1”


k比较小,直接暴力打表!


代码如下:

#include <cstdio>
int main()
{
    int p[17], ans[17] = {0};
    int m, k;
    for(k = 1; k <= 14; k++)
    {
        int n = 2*k;//总人数
        m = 1;
        for(int i = 1; i <= k; i++)
        {
            //因为编号是从1开始的
            ans[i] = (ans[i-1]+m-1)%(n-i+1);
            if(ans[i] < k)//说明杀掉了好人,不符合题意
            {
                i = 0;
                m++;//枚举
            }
        }
        p[k] = m;
       // printf("%d\n",p[k]);
    }
   // return 0;
   int kk;
   while(scanf("%d",&kk) && kk)
   {
       printf("%d\n",p[kk]);
   }
   return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值